Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)
User avatar
By Atombuilder
#61207 Hi,

I connected an A6 GSM module to the serial port of my laptop and I get the startup messages (including current date and time so there is a connection to the mobile network). Then I want to send a simple AT command but I don’t get an answer from the module. I couldn't figure out what is wrong so I suspected the module itself. Perhaps a broken RX port .... ? So I ordered another one, just like the one on Raymond Tunnings' site (https://raymondtunning.wordpress.com/20 ... -and-data/). I thought that way I have the same module and I can follow the instructions on his site. Unfortunately this second module behaves exactly the same. There is readable output when the module boots and connects to the mobile network so I'm sure the baud rate is correct.

How can I do some additional troubleshooting to figure out what is wrong? Any ideas somebody?

Greetz,
Roland
User avatar
By tinkerbear
#65101 I'm having what I think is the same problem. I've also bought a second one, and get the same results - start up text, then no reponse to AT commands.

On the theory that it might be power related, I added some capacitors (both 1000µF electolytic and 10µF tantalum low-esr) to the 5v power just before it enters the module, but it hasn't made a difference.

Waiting 5 or 10 minutes doesn't help. I'm wondering if it could be something with the INT or RST lines, but the chinglish docs aren't helping me understand whether to tie them low, 3.3v high, or 5v high.
User avatar
By Pasu
#65944 I think I found the problem. When powered up the module is in autobaud (trying to guess the host's baud rate)
but it fails miserably if you send one character at a time (if you are typing on your keyboard...)

If your terminal supports macros you could set one to send the string "AT<CR>". Two chars apparently are enough for the autobaud detection to correctly identify your baud rate (you can always use a longer string, even if it's not a valid AT command).

Another method is to turn on the hardware hanshake on your terminal and then connect CTS to DTS on the host side. If you temporarily disconnect these two pins, write AT<CR> on the terminal and then reconnect them, the data will be sent all at once.

HTH

Pasu