So you're a Noob? Post your questions here until you graduate! Don't be shy.
User avatar
By Louis Mylle
#64912 Hello there!

I'm completely new in the world of arduino's, ... but I bought a ESP8266 https://www.amazon.fr/NodeMCU-Development-Internet-ESP8266-ESP-12E/dp/B01GCK3J40/ref=sr_1_1/258-9030735-6382133?ie=UTF8&qid=1492096907&sr=8-1&keywords=esp8266 anyway!

But if I try to flash it with https://github.com/nodemcu/nodemcu-flasher the log says 'Begin find ESP8266' and doesdn't do anything else... and if I try to upload a script with the arduino software I get this error:
Code: Select allArchiving built core (caching) in: C:\Users\louis\AppData\Local\Temp\arduino_cache_632017\core\core_esp8266_esp8266_nodemcuv2_CpuFrequency_80,UploadTool_esptool,UploadSpeed_115200,FlashSize_4M3M_26bdaf0f953bf07ef13464dbd99b5c32.a
Sketch uses 198752 bytes (19%) of program storage space. Maximum is 1044464 bytes.
Global variables use 33018 bytes (40%) of dynamic memory, leaving 48902 bytes for local variables. Maximum is 81920 bytes.
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_open failed


Some of you probably think that I'm a dumbass :lol:
but I hope someone can help me out.. I really don't know what to do further...

Thank you anyway for reading this topic!
User avatar
By alex_g
#64963 What firmware are you trying to flash it with?
Perhaps it might be easier for you to try flashing it with something like esptool.
User avatar
By Louis Mylle
#64970 I'm trying to flash the nodemcu firmware, found on github (https://github.com/nodemcu/nodemcu-firmware/releases). Flashing it with esptool doesn't work either...

I'm getting this error:
Code: Select allConnecting........_____....._____....._____....._____....._____....._____....._____....._____....._____....._____

A fatal error occurred: Failed to connect to Espressif device: Timed out waiting for packet header
User avatar
By taikapanu
#65002 Hi,

At least with arduino ide you need to press and hold "flash" button on right(?) Corner.

ESP need to be in specific mode to be programmed. So from arduino ide press upload, press and hold flash button, press reset once. Reset need to be pressed before actual uploading starts. Not sure if that particular chip resets automatically.

After software is uploaded release the flash button.

Hope it helps :)