So you're a Noob? Post your questions here until you graduate! Don't be shy.
User avatar
By jrullan
#69926 Hi,

I'm kind of a newbie to the ESP8266 with regards to loading the newest AT firmware.
I have tried unsuccessfully to load the newest 2.1.0 AT bin into my ESP.
I'm using the RobotDyn Arduino Uno + ESP8266 board http://robotdyn.com/catalog/boards/uno_wifi_r3_atmega328p_esp8266_usb_ttl_ch340g_micro_usb/.

I followed several blogs and the documentation, and downloaded the firmware from https://github.com/espressif/ESP8266_NO ... master/bin

From there I picked the following files:
blank.bin
boot_v1.7.bin
esp_init_data_default.bin

For the user bin, there are two subdirectories, I used the binary from https://github.com/espressif/ESP8266_NO ... .new.2.bin

Here is the screenshot of the ESP download tool:

Image

And the download log looks like this:

Image

One funny thing I noticed is that the log shows it erases the flash in several places but it's missing a writing message. I expected it to print out some message like "writing at ...".
It didn't show any error either so I was under the impression it worked..

Then after this operation completes the ESP it seems it didn't write the firmware at all.
When I connect to the serial terminal, I can only see data @ 76800 baudrate, instead of at 115200, and only this message shows up:

Image

Can anyone tell me what's wrong?
User avatar
By jrullan
#70013 I finally found the problem. :D

Turns out that the files were apparently corrupted.
I downloaded a fresh copy of the github repository and manually picked the files.

Following a suggestion on the bbs.espressif.com forum, I changed the order of the files so that the blank.bin downloads were first, but I am not sure that was necessary.