Post links and attach files for documentation here, also chat about these docs freely
User avatar
By Koelie2
#17992 Image
Image
I removed the can from two esp-12E that i got from the AI-thinker store on taobao.
that is the altium image they provided of the esp-12E as you can see the routing is completely different + the amount of caps and resistors is completely different. (plus the routing looks really similar to the esp-7 (check the via's (green))
i've been testing the esp-12E now for two day haven't noticed any strange resets though.
im just curious why they provide a different picture for there products. if any body else can check their ESP-12E's that would be great.

edit: they changed their files and are now showing their correct designs.


update:

they are fake!! i found this on a dutch website check these images:

Image
Image
real version:

Image
Image

please share your thoughts.

kind regards,

Koelie2
Last edited by Koelie2 on Mon Aug 17, 2015 9:05 am, edited 4 times in total.
User avatar
By kenn
#18003 Well, there isn't much different between all the various ESP models besides the pinouts, some LEDs, antenna, and the size of the flash... other than they are all the same same main ic (ESP8266EX) and schematic, right?

Supposedly there are some RF optimizations and a bigger flash memory on the -12E, but I haven't yet seen an official schematic or spec, so it's hard to know what the 'right' layout and components are supposed to be for a -12E.

What model are the flash ics ? Can you confirm how much memory they have? Are they working ok?
User avatar
By ficeto
#18037 mine came with 4MB Winbond chips. Board looks exactly the same, but with the flash pins broken out. Does not have antenna connector. Overall the flash is what was good. Until we find a way to boot from SD, I see no good in having the flash pins broken out anyway.
My FTDI could only reliably flash it when chip enable is connected to the reset line and not the reset pin.
Rest is pretty standard :) same as ESP-12
User avatar
By j0hncc
#18063
ficeto wrote:...
My FTDI could only reliably flash it when chip enable is connected to the reset line and not the reset pin.
...


Sorry, I don't understand what you mean by this. Could you elaborate please?
Thanks,
John