Chat freely about anything...
User avatar
By ZeSawyer
#71603 Hello!


Got a simple project. Decode an IR remote for 2 AC's, Daikin FTKC (split) and FFR10CV1 (Cassette). Then re-transmit the signal with an ESP8266.
Managed to control the split unit, but failed at the Cassette. Here are the steps & results:


Steps:
1. Use an IR receiver to decode the remote signal, all AC's share 1 remote controller.
2. Copy the raw data (uint32_t rawData[131] = {4500,2450, 400,350...).
3. Transmit the obtained data by the command: irsend.sendRaw(rawData, 131, 38).


Results:
The split AC responded quite well. The cassette AC, however, did not. I tried to send the command at each frequency from 25 to 45Khz but it's not responding.


- Any suggestions to what I might be doing wrong?
- If my circuit (as attached in the picture) works well with the split AC, should it work with any other devices as well? Or my hardware might be causing the problem?



Thanks :)
Attachments
MySchematic.png
User avatar
By philbowles
#71712 Not sure this is anything to do with the problem, but don't you want a base resistor or a current limiter in line with the ir diode? What's the current through it? What does its data sheet say it should be?
User avatar
By philbowles
#71714 Just checked some specs and the minimum beta of the 2n3904 is 100 so even if you only pull 1ma out of the GPIO you are going to get 100mA through the diode, which must surely blow it? I don't even know how it works at all without going POP. Perhaps it's because of the extremely short pulses and some high frequency phenomenon I don't understand that effectively increases the impedance and reduces the he current or some other magic, but it surely ain't good long term.
I reckon u need a 3k to 4k base resistor to get 25 to 50 mA max through the diode depending on its spec sheet...@38khz
Proper engineer needed!
User avatar
By ZeSawyer
#71717 The IR LED is Vishay high power LED, which is why it could go up to 200mA with no issues.
I put an IR receiver and noticed some loss on the command sent, not sure whats causing it yet