Discuss here different C compiler set ups, and compiling executables for the ESP8266
User avatar
By Narasing
#56516 code uploaded succeeds but ESP8266 (NodeMCU) doesn't run for ESP8266_RTOS_SDK v1.4.0


--
I'm trying to run blinking LED program using ESP8266_RTOS_SDK on LUBUNTU by espressif.
program link-->https://github.com/sarwadenj/ESP8266_RTOS/tree/master/test_2
also i written another program and set WiFi in station mode--->https://github.com/sarwadenj/ESP8266_RTOS/blob/master/wifi/user/user_main.c

I compiled my program using
./gen_misc.sh
and set
STEP 1: use boot_v1.2+ by default
STEP 2: generate bin: user1.bin
STEP 3: spi speed: 40 MHz
STEP 4: spi mode: QIO
STEP 5: spi size: 4096KB
spi ota map: 1024KB + 1024KB

and uploaded code going into Bin_path-->
sudo esptool.py --port /dev/ttyUSB0 write_flash --flash_mode qio 0x2000 user1.4096.new.6.bin

it uploaded successfully but code didn't run. So what should be the problem. is I'm missing something.

Is there any solution for this?
Thanks in advance.
User avatar
By davydnorris
#56532
Narasing wrote:code uploaded succeeds but ESP8266 (NodeMCU) doesn't run for ESP8266_RTOS_SDK v1.4.0


--
I'm trying to run blinking LED program using ESP8266_RTOS_SDK on LUBUNTU by espressif.
program link-->https://github.com/sarwadenj/ESP8266_RTOS/tree/master/test_2
also i written another program and set WiFi in station mode--->https://github.com/sarwadenj/ESP8266_RTOS/blob/master/wifi/user/user_main.c

I compiled my program using
./gen_misc.sh
and set
STEP 1: use boot_v1.2+ by default
STEP 2: generate bin: user1.bin
STEP 3: spi speed: 40 MHz
STEP 4: spi mode: QIO
STEP 5: spi size: 4096KB
spi ota map: 1024KB + 1024KB

and uploaded code going into Bin_path-->
sudo esptool.py --port /dev/ttyUSB0 write_flash --flash_mode qio 0x2000 user1.4096.new.6.bin

it uploaded successfully but code didn't run. So what should be the problem. is I'm missing something.

Is there any solution for this?
Thanks in advance.


Couple of things spring out...

- If your chip is 4M then you need to specify its size as 32m (32m BIT) on the esptool command line.
- you also need to load your user1 at 0x1000, esp_init_data_default.bin at 0x3FC000, and blank.bin at both 0xFE000 and 0x3FE000