Discuss here different C compiler set ups, and compiling executables for the ESP8266
User avatar
By CARPP
#58674 If i create a new project and copy paste the makefile from the example projects i get:

/Makefile:2: ../settings.mk: No such file or directory
/Makefile:18: ../common_nonos.mk: No such file or directory


How can i fix this error?
User avatar
By JonWeightman
#58814 Hi,
Please can someone help (3 days and I cant figure out whats wrong)

I have installed everything according to the instructions and tried to build the project written by Pete Scargill - but I always get the errors below:

CC rboot-stage2a.c
LD C:/scargill-esp-mqtt-dev-fed9f12371cc/build/rboot-stage2a.elf
E2 C:/scargill-esp-mqtt-dev-fed9f12371cc/build/rboot-hex2a.h
Makefile:110: recipe for target 'C:/scargill-esp-mqtt-dev-fed9f12371cc/build/rboot-hex2a.h' failed
mingw32-make.exe[1]: *** [C:/scargill-esp-mqtt-dev-fed9f12371cc/build/rboot-hex2a.h] Error -1073741701
mingw32-make.exe[1]: Leaving directory 'C:/scargill-esp-mqtt-dev-fed9f12371cc/rboot'
C:/scargill-esp-mqtt-dev-fed9f12371cc/Makefile:208: recipe for target 'firmware/rboot.bin' failed
mingw32-make.exe: *** [firmware/rboot.bin] Error 2

Any help would be brilliant !!!!

Thanks
User avatar
By MartijnTiny
#59228 Hey,
Thanks for the great work with this DevKit for the ESP!

But im here with a question. When i use the latest version of this kit, i get an error when i try to disable the interrupts. (error: implicit declaration of function 'ets_intr_lock' [-Werror=implicit-function-declaration]). I have included the ets_sys.h file, and it still keeps complaining. This happens also when i use the macro defined in the ets_sys.h file ("ETS_INTR_LOCK"). Can someone point me in the direction i need to look to fix this?

Greetings
User avatar
By lichtkl
#61092 Hello

I need Help for BME 280 Example Driver (i2c_bme280)

I'am using the bme280 Driver from the examples folder.
In the minus degree it has a bug.

It shows 0,43 and -0,43 and -1,43 and -2,43 and so on , it jumps allways 1 degree ... and nothing between
humidity and Pressure are ok .
i don#t found the bug , can you help please?

best regards
Klaus