So you're a Noob? Post your questions here until you graduate! Don't be shy.
User avatar
By hookitup
#70487
schufti wrote:make sure you can flash with your version 1.
set the baudrate in sketch and serial monitor to 74880
after flashing press the reset button
at least you should see the output of the bootloader
if your sketch doesn't start it should give a hint what is wrong

to be on safe side add pull-ups on rst, gpio0, gpio2


ok i tried changing the baud rate and this is what i get:
Also would a 10K work for the pull up? im not 100% familiar with pullups/pulldowns

Code: Select allBaud rate changed to 74880


 ets Jan  8 2013,rst cause:2, boot mode:(3,6)

load 0x40100000, len 28740, room 16
tail 4
chksum 0xcd
load 0x3ffe8000, len 2888, room 4
tail 4
chksum 0xbc
load 0x3ffe8b50, len 15252, room 4
tail 0
chksum 0x4f
csum 0x4f
R
Communications Error - Check baud rate


Baud rate changed to 9600


Communications Error - Check baud rate


Communications Error - Check baud rate



im not really sure why its saying that when i have both serial monitor and sketch on same baudrate

Also
rudy wrote:Don't use the 3.3v from the FTDI chip. It is not adequate. You need a supply that can handle peaks of up to 500mA.


i noticed the lack of power from the FTDI so i switched to a dedicated power supply.
this is my set up now:



ESP:Rx > FTDI:TX
ESP:TX > FTDI:RX
ESP:VCC > PS:3.3 (PS = power supply if its not obvious)
ESP:CH_PD > PS:3.3
ESP:GND > PS:GND
ESP:GPO0 > Button > PS:GND
ESP:RST > Button > PS:GND
FTDI:GND > PS:GND