So you're a Noob? Post your questions here until you graduate! Don't be shy.
User avatar
By Camren
#71847 Hi All, I have a simple project that requires both WiFi and Ethernet. The Ethernet module is a Robotdyn W5500 and communicates via SPI. On an Arduino UNO it works just fine using pins 10,11,12,13 for SPI.
The Wemos board has all of the SPI functions printed next to the pins but I can't get the module to work. I understand that an ESP is not an AVR but if the SPI functions are marked on the board shouldn't it be almost plug and play?

I am using the Ethernet2 library that supports the W5500 and have been able to do almost anything else on the Wemos except this.

Anybody else run into this?

Thanks,
Bill
User avatar
By gdsports
#71853 The W5500 shield may route SPI signals through the ICSP connector. The WeMos D1 R2 does not have an ICSP connector. Modifications to the shield might solve the problem. However, the shield may no longer be usable on an Uno.

I ran into a similar problem when I connected a USB host shield to a WeMos D1 R2 that also interfaces using SPI. The USB host shield routes SPI via the 2x3 ICSP connector. I was able to get it to work after cutting off the ICSP connector and soldering wires between the ICSP connector holes and the ESP8266 SPI pins. I also had to deal with the shield driving 5V into the ESP 3.3V pins. I got it to work but I will not be doing that again.

https://github.com/gdsports/esp8266-usb-host-demos/wiki

I recommend using a small ESP8266 board and a mini W5500 board that works at 3.3V. This is probably easier than modifying the shield board.