A place users can post their projects. If you have a small project and would like your own dedicated place to post and have others chat about it then this is your spot.

User avatar
By quackmore
#89621 I'd suggest you to clone the nodemcu-firmware repository and build it yourself but looks like you are on windows...

I checked the user_config.h file and ...
Code: Select all// The firmware supports a range of Flash sizes, though 4 Mbyte seems to be
// the most common currently.  NodeMCU builds include a discovery function
// which is enabled by FLASH_AUTOSIZE, but you can override this by commenting
// this out and enabling the explicitly size, e.g. FLASH_4M.  Valid sizes are

#define FLASH_4M

assuming that something went wrong with https://nodemcu-build.com/ and/or FLASH_AUTOSIZE
I built the binary for the FLASH_1M, you will find them here

I tested the same binaries for the 4M flash and the client application and they are working fine
but I cannot test the 1M version because I'm missing such a devices

follow following steps:
1) erase the flash
2) flash 0x00000.bin at 0x00000
3) flash 0x10000.bin at 0x10000
4) reset the device
5) wait a few minutes for the file system formatting
6) reset it again
7) try to connect with ESPlorer

looks like the SDK 3 can generate the missing init data, so you can skip that step (it worked for me)
User avatar
By maxniz
#89622 file downloaded thanks ...i have tried... you can see in "flash" the three files... when i use the two last ,esp isn't able to connect but whit the first ,yes.... in "esp" you can see what appens
infact the esp's led blink only during the flash time and obviously then don't work ..
have you any idea ???
You do not have the required permissions to view the files attached to this post.