A place users can post their projects. If you have a small project and would like your own dedicated place to post and have others chat about it then this is your spot.

User avatar
By maxniz
#89614 don't hate me.... i have requested the file ..This was built against the release branch and includes the following modules: file, gpio, http, net, node, tmr, uart, wifi
but with this, nobody works... i have tried in every mode but nothing... neither my each my old files with this file ,works...
User avatar
By quackmore
#89616 in one of the previous posts I inserted the details of the build I used, they look the same as yours
I'm using WEMOS-D1 mini with bigger flash but your modules should work fine
unfortunately I don't have ESP8266-01 module to verify

checkout nodemcu docs under the "upgrading fw section" (an extract below)
read it all
it could make sense that lua scripts written for really old build won't work on the newest
it could happen that just after flashing the device the first boot takes a while for formatting the filesystem
really old SDK init params could create isses

when I setup my modules I did the following:
1) erased the flash
2) flashed the SDK init files (checkout the docs)
3) flashed the nodemcu binary file at 0x00000

can you get the nodemcu-firmware flashed and working?
can you see the node version ? (checkout the docs for node.info())
try a trivial init.lua script and see what happens

Code: Select allUpgrading Firmware
There are three potential issues that arise from upgrading (or downgrading!) firmware from one NodeMCU version to another:

Lua scripts written for one NodeMCU version (like 0.9.x) may not work error-free on a more recent firmware. For example, Espressif changed the socket:send operation to be asynchronous i.e. non-blocking. See API documentation for details.

The NodeMCU flash file system may need to be reformatted, particularly if its address has changed because the new firmware is different in size from the old firmware. If it is not automatically formatted then it should be valid and have the same contents as before the flash operation. You can still run file.format() manually to re-format your flash file system. You will know if you need to do this if your flash files exist but seem empty, or if data cannot be written to new files. However, this should be an exceptional case. Formatting a file system on a large flash device (e.g. the 16MB parts) can take some time. So, on the first boot, you shouldn't get worried if nothing appears to happen for a minute. There's a message printed to console to make you aware of this.

The Espressif SDK Init Data may change between each NodeMCU firmware version, and may need to be erased or reflashed. See SDK Init Data for details. Fully erasing the module before upgrading firmware will avoid this issue.
User avatar
By maxniz
#89620 the problem is on the build... i have tried with more than one flasher but it doesn'work ..no one file works with the new build... i'll try again today is sunday and i have more time...
tnx !!!!
You do not have the required permissions to view the files attached to this post.