A place users can post their projects. If you have a small project and would like your own dedicated place to post and have others chat about it then this is your spot.

User avatar
By HackAWay
#8042 HI Really like the NTP request looks nice and simple. But not getting a readable response with any BaudRate

Using ESP Flasher I flashed eagle.app.v6.flash.bin in 0x00000. Had to restart the ESP8266, to flash eagle.app.v6.irom0text .bin in 0x40000, keeping GPI0 to GRD the whole time. Then removed GPI0 to GRD restarted.
I get scrambled message using Baud 115200. I tried 9600 which I had set the last firmware to.
No luck, also with 14400, 19200, 28800, 38400, 57600.
Any ideas?

Thanks ED
User avatar
By HackAWay
#8071 Solved my own question! So obvious now in retrospective.

I needed to update the ESP to v0.20 before flashing the NTP servers Firmware and SDK.

If this helps others what i did was, Flashed: v0.20_14_11_28

0x00000 boot_v1.1.bin
0x01000 user1.bin
0x7c000 esp_init_data_default.bin
0x7e000 blank.bin

then flashed: Addition of NTP support for0020000903/0020000904
0x00000 eagle.app.v6.flash.bin
0x40000 eagle.app.v6.irom0text.bin
0x7c000 esp_init_data_default.bin
0x7e000 blank.bin

And Worked A treat!
User avatar
By weisslein
#16836 Hi everybody,

I've implemented a scenario with this ntp firmware 0.9.4 based on the ESP01. The NTP offers me the chance to handle the data via time scheduling.Thanks for the opportunity so far! :D
But now, I've a must requirement to use the ESPs in an environment without internet access.thus I haven't got the possibility to call pool.ntp.org. instead of these pool servers I have installed a local ntp server in the network, which I now want to call.

Does someone know, how I can reach this?
Currently I have made some investigations based on the github rep https://github.com/TomerCo/ESP8266-AT
I've found the sntp.c and I would adapted it in the following way:
#if SNTP_SERVER_DNS /* wil be set to 0 */
#define SNTP_SERVER_ADDRESS "pool.ntp.org" /* will be deleted or empty*/
#define SNTP_SERVER_ADDRESS "" /* will be adapted to the local IP */
Would that solve my problem?
But the repository contains only the src code of SDK 0.9.3 and the AT cmd v20.
Is the source code with the ntp firmware based on SDK 0.9.4 somewhere available?
So, that I can adjust it according to my needs, rebuild/make it and flash finally the ESP.

any help appreciated!

Thx in advance!

User avatar
By weisslein
#18009 hi everybody,

in the meanwhile I updated the SDK 0.9.4 source files with the AT files from Tomer and adapted as mentioned above the sntp.c. After the setup for the toolchain I was able to build the SDK 0.9.4 with the adapted sources and now I can use the ESP module with my local NTP server.