The use of the ESP8266 in the world of IoT

User avatar
By rudy
#85438 Switch off three of the ESPs. Can the remaining one connect?
Switch that one off an switch on a different one.
Make sure that each one works individually. Then power up two.

Does the broker have a log? What does it say?

Can you get one ESP to work and another device like a PC?
User avatar
By dionisis.bozikis
#85464 i solved the problem by setting the wifi mode to WiFi.mode(WIFI_STA) ( meaning station) before calling the WiFi.begin() .
most probably the default mode of the wifi client is AP (ACCESS POINT) or something else, which may be causing the problem of multiple connectivity, because with one esp client was always working, but the rest were unable to connect. something somewhere in the RaspI has saved the one working client as an AP and not allowing others.. probably..
i found the solution here : ... -274112911
User avatar
By petrihau
#90320 Hello,

I have three pieces of Wemos D1 mini pros. I've been using one of them for prototyping. There are BS18B20 and SHT31 sensors connected to it. My MQTT broker is running in Simantic iot2020 and everything is working fine. To finalize my project, I uploaded the functional code to second D1 mini and also to third one. When starting them, I was very suprised that last to pieces can't connect to mqtt broker. I also tried to chance the client ID, but no success. All three can initialize WIFI-connection, but only the I used first can connect to mqtt server. I've been running them only one at the time. Could this be related to MAC -address? Any ideas how to solve this?