Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By Kheitmann
#82110 Hi Guys :)

I'm working with a brand new ESP8266, I bought it on a sparkfun ESP 8266 <<The Thing>> development board: ... troduction

I've connected the Rx and Tx pins to a dsPIC33 Microchip Tx and Rx pins that i have on an old explorer16 development board with an embedded LCD display. (picture 1 "Overview")

The Explorer16 board connects the two UART modules of the dsPIC33 into a socket, I've configured the UART modules in 1 stop bit, no parity and 8 data bits and 115200 baud rate speed, and I've tried to send the "AT\r\n" command to the ESP8266 microchip, but I don't get any answer from it.

I know that the UART module on my dsPIC33 is working fine, because I also have a bluetooth HC-06 device that also uses the AT commands, and I can connect the HC-06 device to the dsPIC33, establish a bluetooth connection with my cellphone, and I can send and receive commands using the HC06. Furthermore, If I connect the HC-06 to the UART1 port of my dsPIC33, and then I short circuit the Tx and Rx pins from the UART2 (the one which I will plug my ESP8266), whenever I send some data through my cellphone, I get an echo from the bluetooth device.

I've tried setting the UART2 baud rate speed to 9600, 19200, 57200, 74880 and 115200 but I can't get any response from the ESP8266 device. I've read on a manual that if you are using a 40 MHz crystal connected to the ESP8266, you must set the baud rate speed to 115200, but if you've got a 26 MHz crystal, you must use 74880 as the baud rate speed (that's why I did use this odd number).

I know that the ESP8266 is connected because the sparkfun board has a pin available that is called "RST", or DTR in some other versions. This pin is connected via a capacitor to RESET, and a buffer to the ESP8266's GPIO0 ( ... e-overview ). If I connect that pin to ground using a wire, the module resets itself and I can see on my LCD display and in my cellphone some "jibber jabber", this unintelligible message appears everytime I connect the pin to ground, and is always the same. It only changes if I change the baud rate speed.

That's why I pin pointed the problem the baud rate speed, I guess I must done something wrong.

Another important information is that I checked that the sparkfun board has two LEDs whose labels are "Tx" and "Rx". I guess this LEDs must blink whenever a message is transmitted (Tx) or received (Rx) in the board. I have never seen these LED's blinking nor lighting up.

Also I noticed there is anothe LED that reads "5" in it's label. Searching on the "Sparkfun ESP8266 the Thing" documentation, apparently This pin is also tied to the on-board LED (see table "General I/O Header" here ... e-overview ). However, when I connect the 5 pin to VCC (3.3 volts) the LED does not light up

Somebody has an idea or suggestion about what to try? Or maybe can pinpoint me to a good resource that I can use to solve this problem?

Best regards,
User avatar
By Kheitmann
#82137 Thanks for your reply.

> maybe there is no "AT" firmware on your esp??? as it is - bluntly - an useless piece of crap.

I didn't think about that, I believe that my supplier would sell me a fully functional piece of hardware, ready to receive AT commands. It may be possible to try to upload a firmware by encoding it into the dsPIC33 microchip? or is it cumbersome? It would be better to buy another piece of HW in order to upload the firmware? Maybe a FTDI cable? I'm completely ignorant on this specific topic, so any help or resource regarding the firmware would be very helpful.

> If you set your explorer16 board to 74880baud you should at least see the boot message of the esp8266.

Yes indeed I receive the boot message from the ESP8266 whenever I put the reset signal to ground on the sparkfun board. However, the response message is completely unintelligible, even if I set the baudrate on the explorer to 74880. I've tried with all the standard baud rate speeds between 9600 and 115200 + 74880 and the message changes depending on the speed. However, I think I always received at least one non readable character from the ASCII table. I will check that again using the 74880 speed and taking note of every character on HEX code I will get. I will do this on the weekend.

Best regards