Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By Ufuk Usta
#82586 Hello, I have a strange problem and I couldn't find any solution and decided to write here for last try.

First of all, I have a PCB has ESP8266 on it and I can say the problem is not related about any GPIO high, low issue and schematic. Because I used the same PCB so many times and it is working.
I bought new modules (22 piece) and I have the same problem all of them.

The problem is, I can flash the NODEMCU or AT firmware successfully however, after reset module is not starting. I couldn't get any response. ESPLORER couldn't detect the firmware. I am only seeing unknown characters on the bus.

I have a copied image from my old ESP8266 modules and even this backup is not working. If I write this backup to my old modules, they are working like a charm without any problem.

So, what could be the problem of this new modules? If I couldn't find a solution I have to buy 22 more :/

Device parameters (NEW ONE - not working:
Code: Select allManufacturer: 68
Device: 4014
Detected flash size: 1MB
Chip ID: 0x00ba837a

Device parameters (OLD ONE - working:
Code: Select allManufacturer: e0
Device: 4014
Detected flash size: 1MB
Chip ID: 0x00fa29cf

CMD output:
Code: Select all....esptool-master> python -p COM8 write_flash 0x0000 .\firmwares\nodemcu- v2.3-dev
Detecting chip type... ESP8266
Chip is ESP8266EX
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Auto-detected Flash size: 1MB
Flash params set to 0x0020
Compressed 465060 bytes to 302984...
Wrote 465060 bytes (302984 compressed) at 0x00000000 in 26.9 seconds (effective 138.3 kbit/s)...
Hash of data verified.

Hard resetting via RTS pin...

As you can see from top, I can read the module parameters in boot mode. There is no any problem to reading and writing to the memory. But, chip is not starting. Please give me an idea.

You do not have the required permissions to view the files attached to this post.
User avatar
By Ufuk Usta
#82730 Hello,

Finally I figure out the problem. It is happening because of the memory chip. Even "dio" is not worked and I tried "dout", now module is working.

Memory chip is:
Boya Microelectronics BY25D80

If your memory chip is that use "dout" mode.
Code: Select allpython -p COM8 write_flash --flash_mode dout 0x0000 .\backup_1mb.img