Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)
User avatar
By alonewolfx2
#7597 Did you try this firmware with your mode? I wonder one thing. Is it working your mode with flash operations after boot. (on the webserver runtime)
Adex wrote:GPIO ale pulled up/down like normal board.

But I must flash with ESP FLASH DOWNLOAD TOOL V0.9.3.1 with selected DIO mode instead QIO mode.
I think that esptool.py might need to have some patching to work with DIO instead QIO mode.

___UPADTE___

I resolved an issue with DIO mode and esptool.py
If you want to flash firmware with esptool.py, you must change third byte in firmware form 0x00 to 0x02 (according to specification from https://github.com/themadinventor/esptool)
When using ESP FLASH DOWNLOAD TOOL V0.9.3.1 application is automatically changing this byte when uploading to device.
User avatar
By Adex
#7602 Which firmware? I tried only 1wire_ds18b20 demo.

But I'll try also esphttp webserver with modified GPIO control.

I'm testing every firmware in crippled SPI mode (memory connected with ESP8266 using normal SPI instead Quad SPI).
User avatar
By Adex
#7609 I tried esphttpd and it works good.
I tried also nodemcu latest build, and altering GPIO9 and 10 (pin 12 and 11 in nodemcu) works just fine.

Also I tried to hook up an beeper (TMB12A05 which draws max current 30mA) and output on GPIO wasn't constant (checked on logic analyzer).
Next I hooked and LED with resistor (draws about 5mA of current) and it was fine.

So If you want to get a lot of current from GPIO better use transistor (preferably MOSFET logic-level).