Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By orca30
#35370 Just for information, my experience. I am using a esp8266-12 and a Crius USB FTDI interface.

Connections like in ... .LARGE.jpg

CH_PD to VCC (permanent)
GPIO2 to VCC (permanent)
GPIO15 to GND (permanent)
GPIO0 to GND (for firmware flash, only during boot-up)
RX to TX
TX to RX

No resistors or capacitors.

Esptool always terminating at 7% or 11% with error "Failed to write to target flash."

No error in Arduino IDE, but Sketch wont start (no reply in Terminal).

Changing ESP_RAM_BLOCK and ESP_FLASH_BLOCK in did the trick. Esptool successful, and sketch running ok. (see post #13640 in this thread)

A similar setup with an ESP8266-01 was running perfect even without changes to
User avatar
By Matthewk
#59030 I may be late to the party but I had a lot of trouble getting started. I think I learned a few things.

Let me start with where I started. Random eBay USB to serial module, jumpered for 3.3V and a USB cable going into a LM317 regulator set to about 3.3V. I did not use pullup or pull down resistors on the module, which is an ESP8266-01. I did have the proper GPIO pin grounded, and yes I did have the ground on the serial adapter and the local ground connected together.

I wound up getting another USB to serial adapter and that worked right out of the box. I had tried another ESP8266-01 as well, but that did not help. Yahoo. The flashing went just like on the Youtube videos.

However, using any tools with the module was problematic. In Lualoader for example trying to read the heap or chipid was dubious. Either nothing or jumbled characters or like one out of 3 times it would work.

I have a few protoboards and I started with another one, and this time used a 12V wall wart going into the 317. I had about 3.4V coming out. With this setup lualoader was even worse. Like one of out 3 times I could get it to even give me noise and one out of 10 times I might get an actual output or part of one.

I got to thinking that perhaps my problem was that the V+ was a bit too high. That with the module getting 3.4V whatever coming out of the serial adapter may not be quite enough to register as a logic 1. I put one 10K resistor in parallel with the feedback resistor on the 317. That helped a bit, right away I got near where I was with the usb based power supply. I added another. Bingo. Every command worked. I could click and get the IP address, I could scan for SSID's. I was able to upload a script.

I also hit on the idea of testing the serial adapter by jumpering rx and tx and booting up a terminal on my computer. As far as I can tell they are both fine. I suspect it was little Vcc differences giving me grief. Sadly I seem to have lost the first one I was playing with.

If you have a 317 based supply and you are having weird issues you may want to try dialing the voltage down a few millivolts and see if that helps.

Now for my problem. I am new to these modules. I can load the flash that came with the version of ESP8266Flasher that I have, but if I go to the custom build site for nodemcu and do just a basic build with no other stuff checked off and download both the int and the float versions, they seem to flash just fine but when I power up the board all it does is spits out gibberish. I have tried this like 3 times now. I select the file and tell it to put it at the 0x0000 address. Am I missing something?