Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By laukejas
#85852 Hi,

I have a Wemos D1 Mini ESP8266 module which I'm trying to run from a 2400 mAh Li-Po battery through a MT3608 boost module. The wiring is simple:

Li-Po positive and negative to VIN+ and VIN- of MT3608 respectively;

I also hooked up a multimeter in series to measure the current:


As you can see, when I switch on the setup, my ESP draws 144 mA, and does not boot. For reference, it should be drawing around 70 mA. Battery is properly charged. MT3608 is set to output 5V.

Now, this is where it gets interesting. If I replace the Li Po with NiHm battery pack, suddenly the ESP boots perfectly! No issues whatsoever. But I need it to run from Li Po.

So I tried swapping this 2400 mAh Li Po to 2800 mAh and even 10,000 mAh (single cell) batteries that I have. Same result.

Then, I tried adding 470uF electrolytic capacitors between the 5V and GND. It took 5 (!) capacitors before ESP finally booted correctly.

I strongly suspect that Li Po is not providing enough current to handle the peak of ESP boot cycle. I remember reading that this peak can go up to 437 mA. But then again, my 2400 mAh Li Po is rated at 1C (max discharge current), meaning that it should be able to provide 2.4 A - well above that peak.

I tried swapping every single element of the circuit - ESP, battery, boost module, wires, even the multimeter. Nothing changes.

Can anyone please offer any suggestions as to why ESP gets stuck in boot with Li Po that should easily handle the current peak during that boot? Why do I need to add so many capacitors in order to make it work?
User avatar
By rudy
#85869 One of the remotes I made is similar in design to yours. I use a 18650 battery followed by a boost module like that (same design but different layout). I have a 47uF capacitor on the output of the booster and also 47uF at the ESP8266 board. The board I am using for the ESP8266 is one of those cheap crappy white breakout boards that sell for about $2 for 10 pcs. The board has a regulator and a couple of resistors.

I added the 47uF at the output of the converter but that wasn't reliable. So I put another 47uF right on the board with the regulator & ESP12 module. I had used about the same length of wire between the converter and the ESP as you have. The capacitor at the ESP made the difference.

I use an 18650 battery so I have a lot more current available for the converter. I have a switch to connect the battery to the converter.

Try soldering a capacitor at the board.

Try a 10uF capacitor on the enable (EN) to ground. I'm wondering if the rise time of your setup can be causing a problem. Maybe the power is coming up too slowly.

A digital oscilloscope would be handy to see what the startup voltage looks like.

Another thing you can try is to connect a switch from EN to gnd, before adding the above. Hold the chip in reset, let the power come up, then open the switch and see if it starts. If so then the delayed enable would probably work.
User avatar
By QuickFix
#85878 Just a heads up (but I guess you're already aware of this), but there are battery power shields for the Wemos that also let you charge the battery. :idea: