Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By Herrero
#87381 I have strange problem with the wifi connection. I have decided to ask you for help because it happens second time. Last time after few day of fighting I threw it in the bin (it was Nodemcu V3 Lolin with metal shield on chip). Now it is nodeM from robotdyn. Generally the module worked fine (it was able to connect to wifi etc.). After the next programming the module is unable to connect to my router. I was trying:
- erase whole flash via esptool (erase_flash),
- flash with last "esp_init_data_default_v08.bin" from SDK via esptool
- WiFi.disconnect() etc.

Each time looks that everythink is ok (no errors during flashing), but my module is not able to connect to any AP. If I run soft AP I'm not able to connect to it (I see SSID).

If I run basic example from wifimanager, the output is:

Code: Select all*WM: [1] No Credentials are Saved, skipping connect
*WM: [2] Starting Config Portal
*WM: [3] WIFI station disconnect
*WM: [3] WiFi station enable
*WM: [2] Disabling STA
*WM: [2] Enabling AP
*WM: [1] StartAP with SSID:  AutoConnectAP
*WM: [2] AP has anonymous access!
*WM: [1] SoftAP Configuration
*WM: [1] --------------------
*WM: [1] ssid:             AutoConnectAP
*WM: [1] password:         
*WM: [1] ssid_len:         13
*WM: [1] channel:          1
*WM: [1] authmode:       
*WM: [1] ssid_hidden:     
*WM: [1] max_connection:   4
*WM: [1] country:          CN
*WM: [1] beacon_interval:  100(ms)
*WM: [1] --------------------
*WM: [1] AP IP address:
*WM: [3] setupConfigPortal
*WM: [1] Starting Web Portal
*WM: [3] dns server started with ip:
*WM: [2] HTTP server started
*WM: [2] WiFi Scan completed in 2182 ms
*WM: [2] Config Portal Running, blocking, waiting for clients...

I have question: should be the coutry code set to CN? I have change it to US, bo no difference. After restart again is CN.

I was also trying (at the beginning) wifi scan example, the output is:

Code: Select allscan start
scan done
1 networks found
1: ESP_CC23F1 (-68)

scan start
scan done
no networks found

Why the module is finding only one network? At my place there is a lot of wifi networks. Is that a coincidence that every time is finding espressif network (different working nodemcu)?

How to recover the module?
User avatar
By davydnorris
#87388 I haven't gone through your problem in detail but just wanted to post one observation that happened to me:

I had a similar situation where I could see over a dozen networks on my iPhone, but my ESP couldn't see any, but would happily see my iPhone hot spot. It turned out that all the other networks were 5GHz and my phone is dual band WiFi, whereas the ESP is only single band 2.4GHz.

That may cull your list down a bit?
User avatar
By Herrero
#87394 I think that the problem is not an unpropper band. At home I have above 20 esp8266 (the sensor network) and they are periodically scanning the band and store results on my server. All of them are able to list over a dozen wifi networks. Infortunatelly this unit is a part of my irrigation system and it is soldered to other parts. Thats why I'm trying to find out source of the problem.