Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By ahargunamatarp
power mode 1 yellowed.JPG
Inkedpower mode 2 yellowed_LI.jpg

I'm testing two 3.3V Relays (with optocoupler) on NodeMCU ESP8266. But it seems that if I connect any Relays to this 3.3v and GND (mark with yellow color on the picture) PIN, the Relays are unable to switch/click (marked with green LED and the sound).

Sometimes the green LED is on, but the switching/clicking sound does not appear. And I tried to connect a 12V CPU FAN to that Relay that is connected to that yellowed PIN. But the FAN is not turned on even though the green LED on Relays is on. I tried to use a 9V battery and adjustable power adapter at 8.5V that is connected to the FAN and Relay but the issue still persists.

The other Relay that is connected to another port on this image is working alright. Is it related to the hardware issue?

I also have a question regarding this second image. Relay that is connected to that PIN (marked with orange color on the wire) sometimes working alright, sometimes it is also having a similar issue. Green LED is turned on but the switching/clicking sound is not heard.
You do not have the required permissions to view the files attached to this post.