Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By x5442
#4257 See the post above by martinayotte - GPIO16 must be connected via a jumper (solder or 0R resistor) to EXT_RSTB to make it work as reset.
User avatar
By gwizz
#4551 I've been playing with my new ESP-03's from electrodragon for a couple of days and I am tearing my hair out!

I've tried every baud rate and still can't get anything on a terminal that isn't rubbish!! :cry:

My trusty USB bub II thingy blew the other week so I'm using a raspberry pi to connect to the UART interface.

To invoke a terminal on the pi I first edited /etc/inittab to disable the serial console, then use:

Code: Select allpicocom /dev/ttyAMA0 -b 9600

All I get at any baud rate is gibberish with occasional control characters that clear the screen etc!!

I also tried to upload new firmware, also without success. :(

I've checked for soldering problems and tried most combinations of GPIO's to VCC/GND I can think of.

(photo shows my setup but don't worry about the connections shown - I tried all the versions listed in this thread and many more!)

Any bright ideas?

Thanks in advance

You do not have the required permissions to view the files attached to this post.
User avatar
By zdebel
#4552 GPIO15 must be pulled down to GND, that's the only requirement. It is possible your module didn't come with firmware loaded into it. To flash it, you need to pull GPIO0 down and do a reset, it'll go into the bootloader. The tricky part is the reset isn't broken out, you need to solder a wire to a spare goldepin from a not installed resistor near the red wire. It is mentioned in another topic.
User avatar
By joostn
#4553 Did you not forget to connect GND of the module to GND or your rPI? Otherwise the two will be only AC coupled.
And do you use a proper 3.3V power supply? I don't think the PI can power the module.
Connect GPIO0 and GPIO15 to GND, CH_PD to VCC before powering up the module.
Then launch esptool to flash a .bin file.