Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By somedude
#44533 Hello,

I have an ESP-12 on the Adafruit Huzzah breakout board.
It came with Node MCU and I need it to run the default/original firmware that interprets AT commands.
My plan is to make it the WiFi module for an Arduino.

I found a tool and firmware to upload v0.9.5.2 AT Firmware.bin and now after it boots it says MEM CHECK FAIL!!! and then Ai_Thinker Technology Co. Ltd. and ready.
It won't however accept any AT commands, if I send a plain AT it locks up puTTY.

Since there is so much weird stuff that I can find on this topic I decided to post.

I believe I have two issues:
- find a source of a reliable and up to date firmware for ESP8266 - ESP12 that interprets AT commands
- find a solid flasher for it, after having tried ESPflasher from NodeMCU as well as ESP8266 Download Tool 2.3 and 2.4 (seemingly from Espressif) and also XTCOM Util (which I find easier to use)

I may have another issue, as I may have messed up my ESP, since I now get the MEM CHECK ERROR, but that may be the topic of another post.

Anyone that could point me in the right direction?
Thank you very much.
Last edited by somedude on Thu Mar 31, 2016 1:08 pm, edited 1 time in total.
User avatar
By somedude
#44535 Update:

I found this great write-up: ... fi-module/

I am currently trying to flash from here:

EDIT: no dice
I tried both 1.4 and the older firmware with the AT bin to no avail.
Neither combination works, all I get it a ready prompt but no response if I issue an AT.

Back to square one.

Any suggestions would be greatly appreciated. Thank you.
User avatar
By somedude
#44591 OK, for the benefit of other users, here is the solution that worked for me:

I downloaded the latest NONOS 1.5.2 SDK from Espressif:
The link to the zip file is towards the bottom of the page.

I downloaded the 2.4 flasher from Electrodragon:

After unzipping the flasher and the SDK, I launched the flasher, unchecked all boxes for the files and clicked START after selecting the right COM port.
This loads the setting and parameters of the device. Since I use an ESP8266 module with the ESP-12 chip, namely the Adafruit Huzzah breakout board, I can't be sure that the rest of this post applies to your setup, but it will for the Huzzah.

In the esp SDK zip file there will be a bin folder with several bin files. In the at subfolder you will find a very important readme.txt file that is key to a successful flash.

For my chip I used this chapter as a base to flash the bins:

***********************BOOT MODE***********************
[... snip ...]
Flash size 32Mbit: 512KB+512KB
boot_v1.2+.bin 0x00000 0x01000
esp_init_data_default.bin 0x3fc000 (optional)
blank.bin 0x7e000 & 0x3fe000

This is what matched up with what the flasher reported for my chip, so I used the following file settings:
esp_iot_sdk_v1.5.2\bin\boot_v1.5.bin at address 0x00000
esp_iot_sdk_v1.5.2\bin\at\512+512\ at address 0x01000
esp_iot_sdk_v1.5.2\bin\esp_init_data_default.bin at address 0x3fc000
esp_iot_sdk_v1.5.2\bin\blank.bin at address 0x7e000
esp_iot_sdk_v1.5.2\bin\blank.bin at address 0x3fe000

I then flashed it by clicking START with a baud rate of 115200 and it was done shortly.
You can watch the progress in the CMD box that opens with the flasher.

Once it's done flashing and the com connection is closed, you can reset the board and watch the boot messages in puTTY or your terminal of choice.
It should report AT v0.60