Here we can all chat about fixing the AT+ command structure and the associated responses.

User avatar
By longinus
#1690 Hey igrr!

I'm trying your firmware but I'm having an issue..
I didn't compile it though, I'm using the prebuilt binaries on your website (dunno if they are the latest version).

It seems after boot it only accepts one command, like AT... (and returns OK).. after that, any command I give will return ERROR.

When I flashed it the first time, it seemed to remember my AP settings.. and tried to connect.. it gave me this on boot.

But then returned error on any AT command.

I then flash a standard firmware (just to see if I was having any flashing issues) and yours again. Now it doesn't show the CWSTAT (probably because it doesn't have an AP saved), but it still gives me error.

This is what I get on bootup with 75000 baud.

Code: Select all ets Jan  8 2013,rst cause:1, boot mode:(3,6)

load 0x40100000, len 23656, room 16
tail 8
chksum 0x3d
load 0x3ffe8000, len 2692, room 0
tail 4
chksum 0x90
load 0x3ffe8a90, len 4452, room 4
tail 0
chksum 0xc2
csum 0xc2
User avatar
By igrr
#1703 Looks like your terminal application is sending LF after CR, and my firmware expects the lines to be terminated just by CR (because that's what the Recommendation mentioned above says).
I'll add code to handle LF at the end of the line to make more terminals happy :)
Btw my firmware only accepts capital letters in the command body. So "at+gmr<CR>" won't work but "AT+GMR<CR>" will and so will "at+GMR<CR>". I'll fix that, but it's on a low priority for now.
User avatar
By longinus
igrr wrote:Looks like your terminal application is sending LF after CR

Yep, that was the issue! When I switched to just sending CR it worked fine...
Then I also tried the new version to see if it worked with CR+LF, and it does too... so this seems to be the best way to have good compatibility! :)

I tried all the commands that are implemented, and they seem to work well! The IP part is not fully implemented yet, right?
I like the debug mode! It showed useful messages like when I tried to list the AP but I was in AP mode "target/esp8266/wifi_commands.c@84: not in sta or sta+ap mode". Made it easier to figure out the issue..

Might be cool if they had specific error numbers that could be toggled on for the standard ERROR message, like ERROR:52. So it's easier to automatically parse issues in a setup without full debug mode.