Questions with regards to ESP8266 Basic and hardware interfacing and control via Basic commands

Moderator: Mmiscool

User avatar
By Lunte
#84495 Hello,

when I write the following code
print "Hello World"
and I press "Save", the blue LED from then ESP-01S flashes shortly and the ESP-01S hangs and is no longer available, only after a new flashing of Basic
when I press "Run" without "Save" only "Done" without "Hello World" is to see in Explorer
that happens with version 2 and 3

what am I doing wrong ? Please help

"please excuse my english I live in Germany"
User avatar
By Mmiscool
#84515 The black esp-01 modules need the 1m version. Select 1m from the flasher drop down.
User avatar
By Lunte
#84582 Hi,

I tried it again. ESP Basic 3.0 Alpha 69 1m Version, I can connect via Wi-Fi I can enter a program, but if I press the save button then the blue LED flickers and that's it, the ESP stops responding, when I reconnect with the ESP and calls the browser says "The page has rejected the connection" only when I re flash the Basic to the ESP I can go back to the Basic.
The Chip ID is ESP8266EX 242019 JB00PNXF15 the other Chip on the Board is P25Q80H8B1F88D
I have tried a capacitor 680 µF between VCC and GND, different 3.3 volt sources, the result is always the same.If I start the test program without "Save" only Done is to be seen in the Browser and i can go back to the edit Window only on "Save" the System hangs.
I've also used different browsers and tablets and phones ever the same.
Also the small wire bridge as to see in the video is soldered.
With Node MCU does not have the problems, it all works fine.

Best regards