You can chat about native SDK questions and issues here.

User avatar
By stark2k
#93312 Hi! Pretty new to ESP8266 programming, I had some pretty straightforward experiences with NodeMCU units and ESP8266 RTOS SDK.

I got a few ESP-12E units and code burner ( this one - with ESP22E - not ESP01 )


Insofar I was not able to communicate with ESP-12E properly.

I tried to read flash ID with
Code: Select all --port /dev/ttyUSB0 flash_id
but no matter what baudrate I supply - it always results in this

Code: Select all> --port /dev/ttyUSB0 flash_id v2.4.0

A fatal error occurred: Failed to connect to Espressif device: Timed out waiting for packet header

With the MCU the output is as expected
Code: Select all> --port /dev/ttyUSB0 flash_id v2.4.0
Detecting chip type... ESP8266
Chip is ESP8266EX
Features: WiFi
MAC: xx:xx:xx:xx:xx
Uploading stub...
Running stub...
Stub running...
Manufacturer: d8
Device: 4016
Detected flash size: 4MB
Hard resetting via RTS pin...

Same USB cable, so I ruled out the potential problem with USB.

When I try to communicate with TTY interface via minicom I get this after pressing flash+reset buttons and then releasing flash and reset.

Code: Select allbrlrl

The contacts on the board look good and I also tried with a few more chips I received - the result is always the same.

Any ideas how that should work / whether I am missing something?
You do not have the required permissions to view the files attached to this post.