So you're a Noob? Post your questions here until you graduate! Don't be shy.
User avatar
By SandUhrGucker
#59362 I build a PCB with a comfortable pinheader-slot for trustable flash, and normal operation with my esp01´s.
Therefore I can successfully flash the 0.9.5 NodeMCU which is included in ESP8266Flasher.
When I switch to normal-mode, I'm able to communicate with NodeMCU 0.9.5.
I can do this with Windows, and also with screen/pytool in linux.

I failed every try to flash a custom build FW. I tried a few times with - no FW runs.
I'm aware most esp01 have "only" 512K flash, but my customs are less than 430k.
For sure I tried different baud-rates, but now I run out od idea's.... Please Help!

User avatar
By Matthewk
#59510 I am having the same issue with a bunch of -01's I got off of eBay. I found a couple other threads and people who have found solutions. They all used the python script to flash and found messing with the options generally got them going. I use the ESP8266Flasher, so I don't have access to as many options. It seems that the bulk of the problems is selecting the wrong flash size. I lost my fdti so I am stuck waiting for a new one to arrive. BTW, when I say lost I literally mean lost. My room seems to have absorbed it. I put it down and now it is gone.
User avatar
By faxMan
#59554 With later versions of firmware i had to also burn a boot.bin file first. I think it has to do with the size of the bins or the new memory maps. Maybe the page below will help. I've switched to the arduino ide so i haven't burned any node mcu lately.