So you're a Noob? Post your questions here until you graduate! Don't be shy.
User avatar
By elektronik
#67023 Hi
I have ESP-01 module. When I bought him, he had SDK V1.5.4.1 and command AT+CWLAP worked properly.

I have updated the firmware to the latest one SDK V2.1.0

AT+CWLAP command does not find the network.

Sometimes he will find one network (With old SDK is 10 network)

Command AT+CWJAP="SSID","password" return

I tested CWMODE 1 and 3.

Does anyone have any idea?
SDK V2.1.0 has SNTP Which I need
User avatar
By QuickFix
#67073 Someone else here on the forum is having the exact same problem.

My guess (upto now) is that:
  • you're using the wrong .bin-files for your flashmemory (4Mbit <=> 8Mbit)
  • the latest firmware simply doesn't support your (4Mbit?) device anymore (or isn't properly tested).

You'd better go back to an older version that still works. :idea:
User avatar
By elektronik
#67128 I have 8Mbit Flash.
When I upgraded to SDK 2.0.0 AT+CWLAP command also does not find the network.
The problem was solved.
I erased the chip (25F08) and uploaded the firmware again on empty flash.
Strange case, but it works :)
Sorry for the spelling, but I'm from Poland.