So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By JJ Goh
#77623 I am new to arduino and receive my arduino set during weekend. I have a ESP 8266 01

Initially I connect it via 3.3 V on arduino UNO ( which I found out it is not recommended) and did not step down 5v TX or RX pin to 3.3v
I did get respond with AT command. I able to connect to the WiFi.
I the meanwhile I did change the baud rate from 115200 to 9600 and switch it back
I did upload blink sketch to ESP 8266, keep getting error regarding EPOM but eventually i able to upload it. But blue light did not blink. (without step down RX voltage)

Now ESP 8266 didnt respond to at command and I am unable to detect the WiFi. It did send garbage message which I cannot read to the serial monitor when it power up.
It respond to ESPFlashDownloadTool and I able to flash the firmware ( I was thinking it like an iPhone, flash it with official firmware able to solve the problem)
I know it might sound stupid,
I connect 5v power source (arduino) and adjust a potential meter with multimeter to supply 3.3V
Create a voltage divider for RX pin

What should I do now to make it work again ?
User avatar
By PtrO
#77648 Good news, as you can up/download firmware; the esp01 does not looked to be bricked. The bootloader proces is (still) operational. Perhaps/likely you've wiped the "AT" command firmware.

In case overpowering the esp8266 some (connected) GPIO pins might burned out and could make the device functionally unusable. Getting garbage form serial, try other baudrate speeds/settings.

The best thing you can do is either reload your "AT" firmware or use your own Arduino-IDE/esp8266 sketch.
See for some resource: During this process, do no forget toe wipe the flash as settings may else be remembered. Of course you can reload some other firmware.

Personally, I would program/compile/load my own firmware using the Arduino-IDE in esp8266 mode.
User avatar
By JJ Goh
#77813 Hi this is the latest update.

My hardware Esp8266ex chip has the following information engrave on it:

The flash memory (I tried my best to read the info with magnifying glass) This should be a 8Mb size chip.

My connection :
arduino reset to ground
arduino 3.3v - 3.3, EN
tx - tx
rx - step down with voltage divider rx
ground to ground & gpio (when uploading flash)

When I connect my serial monitor show random symbol

I tried to upload latest AT command and Aithicker command bit it failed to respond to AT command.
I think I might setting the wrong address because I am confused with Kb and KB.

I have addition question,
1) There is so many at version 1.6.2, 1.6.1 , 1.6 on the official website does it matter?
2) For example, in V1.5.1 there is boot v1.2 boot v1.6 boot v1.7 which to choose
3) what is the different in between at and at_sdio ??

FYI I did tried to flash with nodemcu and official flasher, both return MAC address. So my ESP 8266 still havent brick ?