Page 1 of 1

"could not open port u" "the system cannot find the path..."

PostPosted: Wed Sep 11, 2019 5:08 am
by spaceman

In the past week I used the Flashing tool several times, and it worked well.

Today when I loaded it and tried to execute an "SpiAutoSet" on a board,
I get an error appearing in the Command Prompt window

"could not open port u" "the system cannot find the path specified"

Please see here:


This is how the Flashing tool's window looks:


What might be causing this problem?

I tried it on several different modules/boards,
and of course made sure to be in Programming (and not Communication) mode,
and press the Reset button before starting...

And of course I am on the correct COM Port,
since I checked it via switching to "Communication" mode, and sending AT Commands, and receiving replies successfully..

Re: "could not open port u" "the system cannot find the path

PostPosted: Fri Sep 13, 2019 5:20 am
by spaceman

If anyone comes here via google, the solution is this:

I could not solve this via deleting the program's folder, and reextracting it,
so I decided to sitch to the Comamnd Line tool called esptool.py:

I followed the instructions there:
installed Python v3.7,
installed esptool.py via pip,
and now it works.

I can get status data from the board, and also flash the board successfully.

Also a Command Line tool is much better, since you can save your commands for future use,
which makes life much easier.

Another useful tip:
It seems that Firmware v1.6.2 flashes with no problem,
and Firmware v1.7.1 does problems, and for some reason does not run well after flashing.
So use v1.6.2 for simplicity.