So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By Thomas Meier
#86987 Hey coreywi,

sounds like an easy solution. I have two NodeMCU (ESP8266EX) and both don't respond to AT commands. No idea what's flashed on the device.

I have downloaded the flashtool from Espressif and the AT bins ( ... d%5B%5D=14) but it's a little over my head to a) select the various bins and b) provide the locations to flash them to.

Given you have an easy working bin would you be able to give me a copy of your bin?

coreywi wrote:SOLVED!

I downloaded the utility which has an option to READ firmware. So I found a 8266 board that I had not flashed yet (that still had the AT commands enabled), read the firmware, then wrote it to one of the boards that did not work: -p COM9 -b 115200 read_flash 0 0x200000 flash.bin

Then I loaded the firmware into the non-working board using esptool.exe:

esptool.exe -vv -cd nodemcu -cb 115200 -cp COM9 -ca 0x00000 -cf flash.bin

Silly way to do this, but it finally worked! Thanks for all your support.