Page 1 of 1

Possible bad batch of ESP-01s?

PostPosted: Sun Apr 18, 2021 6:12 pm
by gubbish
Hi all,
Newcomer to the forum, nice to meet you.
I have been using ESP-01s with the standard AT firmware in a project for a few months, everything seems to be working well with them. I recently got a batch of ESP-01s which are just not behaving in the way which I would expect, and I'm wondering if this is just a faulty batch or if I'm doing something wrong.
Other batches of ESP-01s I've used will come right up to the 'ready' string at 115200 baud after sending the init code at 74 kbaud or whatever the specific speed it. On these, no 'ready' comes up. I first checked at all baud rates between 2400 and 500kbaud, no response on any of those. Then looked at the serial data in a logic analyzer. I see the initialization code which lasts about 6ms or so after reset, and confirmed that the bit duration was 13.5us, so corresponding to 74kbaud. Then I see a gap of about 4ms and additional data which also appears to be at the same 74kbaud rate. I was not able to view the actual data as my uart doesn't support the speed.
After that I tried flashing the latest AT firmware using esptool.py on a raspberry pi. This has been working fine with every other batch of ESP-01s I've tried. There were no errors during the flashing process and verification seemed ok. However after this, I observed the signal again after reset and now only the initialization code happens for about 6ms, then no additional data is sent. Usually what happens is the 'ready' string will be sent after about 10-11ms after reset. The units do not respond to AT commands at any speed.
Wondering if anyone had encountered something like this. For now I've just ordered some units from a different seller, but wanted to figure out what was up. Please let me know, thanks!