So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By rjl_tx
#95263 I purchased a pack of 4 esp8266 modules on Amazon from MakerFocus. I get the following when it powers up.
wdt reset
load 0x40100000, len 27728, room 16
tail 0
chksum 0x2a
load 0x3ffe8000, len 2124, room 8
tail 4
chksum 0x07
load 0x3ffe8850, len 9276, room 4
tail 8
chksum 0xba
csum 0xba


The first part prints at 74880 and 'ready' prints at 115200.

The problem is I can't get anything to respond after the ready prompt. Here's what I've done:
Verified rx and tx are at 3.3V.
Used putty to send AT<enter><ctrl-J>
Used esplorer to send AT (esplorer says it can't detect fw.)
Tried to program with esplorer, cannot sync.
Tried 2 of the modules, same thing.

I question if this devices has the AT firmware loaded. What does the ready prompt mean? What commands should it accept?

Any help is appreciated.
User avatar
By rjl_tx
#95271 Nevermind. :D

I reverified my usb to serial device and found it to be bad. It was one of the first things I checked and must have gone bad before I figured out the cr plus lf requirement.