So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By David_B
#95421 Hello all,

I am a newcomer to the world of the ESP8266. I am trying to use an ESP8266 to mod an Olympia InfoGlobe. I previously asked a question about doing this mod here on GitHub, and ended up getting help with implementing the hardware mods. The hardware mods were completed for me based on instructions provided here:

I am now trying to program the ESP8266 that was installed in my InfoGlobe, but I am having an issue with the code uploading, but not executing on the microcontroller. I am currently trying to test using the following code to print to serial output:

Code: Select allvoid setup() {
  // put your setup code here, to run once:
  Serial.println("Hello, you've entered setup()...");

void loop() {
  // put your main code here, to run repeatedly:
  Serial.println("Good day, you're in loop()...");

The output that I get in the Arduino IDE when uploading this is the following:

Code: Select allExecutable segment sizes:

ICACHE : 32768           - flash instruction cache

IROM   : 236036          - code in flash         (default or ICACHE_FLASH_ATTR)

IRAM   : 26729   / 32768 - code in IRAM          (IRAM_ATTR, ISRs...)

DATA   : 1496  )         - initialized variables (global, static) in RAM/HEAP

RODATA : 944   ) / 81920 - constants             (global, static) in RAM/HEAP

BSS    : 25608 )         - zeroed variables      (global, static) in RAM/HEAP

Sketch uses 265205 bytes (27%) of program storage space. Maximum is 958448 bytes.
Global variables use 28048 bytes (34%) of dynamic memory, leaving 53872 bytes for local variables. Maximum is 81920 bytes. v3.0
Serial port COM4
Chip is ESP8266EX
Features: WiFi
Crystal is 26MHz
MAC: 30:83:98:86:3c:58
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Auto-detected Flash size: 4MB
Flash params set to 0x0340
Compressed 269360 bytes to 197740...
Writing at 0x00000000... (7 %)
Writing at 0x00004000... (15 %)
Writing at 0x00008000... (23 %)
Writing at 0x0000c000... (30 %)
Writing at 0x00010000... (38 %)
Writing at 0x00014000... (46 %)
Writing at 0x00018000... (53 %)
Writing at 0x0001c000... (61 %)
Writing at 0x00020000... (69 %)
Writing at 0x00024000... (76 %)
Writing at 0x00028000... (84 %)
Writing at 0x0002c000... (92 %)
Writing at 0x00030000... (100 %)
Wrote 269360 bytes (197740 compressed) at 0x00000000 in 17.5 seconds (effective 123.0 kbit/s)...
Hash of data verified.

Hard resetting via RTS pin...

When I try to use the Serial Monitor to watch for output, nothing is printed. The only time anything gets printed to the Serial Monitor is the following gibberish whenever I push the button on the controller: rll�r$�n � l� b|���rb� b�nnlnnb bpp�$blrl

What is going on here? I am sure I am doing something wrong, but I do not know what that would be. I do not know if this is relevant, but I have tried power cycling the device, but that has not helped. Additionally, the on-board LED flashes quickly when it is plugged back in to a power source.

Any help would be greatly appreciated.
User avatar
By David_B
#95422 I just realized that in my initial post, I failed to mention what kind of ESP8266 I am using. They were acquired from Amazon. Here is the link for them:

Unfortunately, I do not have a second ESP8266 on hand to test installing in the InfoGlobe, however, I did ask the person who did the hardware mods for me to try testing the sample code above on one of the other ones in the package, and he managed to get it working.

This is what he saw when he tried the code: