So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By Larkbox
#95855 I have a number of sonoff basic devices mostly running tasmota firmware. on attempting to install WLED onto a 'new' device over the last w/end i ran into problems in that only 1 computer in my possession (out of 4 tried 2 x desktops with wifi and 2 x laptops ) could see the ap hosted on the 8266 and attempt connection Failing to pass the authentication with the default wled1234 password.. after a bit of frustration.. i pull;ed another module from my limited stock and flashed and proceeded without issue.

But in my 'toybox' i had another problem module discovered some time back. I pulled this and compared the 2 with attempts to flash WLED and TASMOTA and a few arduino example sketches.

Both 'dodgy' devices exhibit the same behavior in that any AP hosted is only visible to one possible client computer ( a 10yr old i5 laptop) and that any attempts to provide valid credentials to an AP that requires authentication fails. and while 1st pages served from unprotected accesspoints can be received such as the tasmota wifi credential save page, attempts to save data /pass back credentials falls over or times out.

when the arduino example sketch to query and list local ssids was flashed it worked as expected.

when the arduino example sketch to host a password protected AP was flashed valid authentication just failed.

Flashing was accomplished using the and i used the erase all option between flashing different firmwares.

2 modules both exhibiting the same behavior?? I think i should be looking for a common h/w component failure ?? if so how should i proceed? IF not WTF?

any help and direction is appreciated

Thanks in advance
User avatar
By rooppoorali
#95895 It sounds like the two Sonoff Basic devices you are having trouble with may have a hardware issue that is causing them to have difficulty hosting an access point and accepting authentication. One possible cause could be a problem with the wireless module on the device, which is responsible for connecting to WiFi networks and creating an access point.
It could also be a problem with the microcontroller or other components on the device that are preventing it from functioning correctly when running certain firmware.
You can try to further diagnose the problem by attempting to flash the devices with different firmware versions or by using a different flashing tool. You may also consider testing the devices with a known-good microcontroller or wireless module to see if the problem is isolated to a specific component.
If you are not able to diagnose and fix the problem yourself, you may need to contact the manufacturer for support or consider replacing the devices.