Current Lua downloadable firmware will be posted here

User avatar
By Thomas Jakober
#84368 Hi, I tried to update my software using the ds18b20 module to the new lua module in version however it wont load:

Code: Select allNodeMCU built on provided by
   branch: master
   commit: 310faf7fcc9130a296f7f17021d48c6d717f5fb6
   release: 3.0-master_20190907
   release DTS: 201909070945
   SSL: false
   build type: float
   LFS: 0x0
   modules: ds18b20,encoder,file,gpio,net,node,ow,rtctime,sjson,tmr,uart,websocket,wifi
 build 2019-10-30 20:14 powered by Lua 5.1.4 on SDK 3.0.1-dev(fce080e)
lua: cannot open init.lua
ds18b20 = require("ds18b20")
ds18b20 = require("ds18b20")
stdin:1: module 'ds18b20' not found:
   no field package.preload['ds18b20']
   no file ''
   no file 'ds18b20.lua'
stack traceback:
   [C]: in function 'require'
   stdin:1: in main chunk

I downloaded the new firmware using the service. Is this effect only on the build service?

By the way I would like to inform you about a minor typo in the nodeMcu Documentation:

node Module

node_verion_major (number)
node_verion_minor (number)
node_verion_revision (number)

these three lines are missing the 's' in 'version'
User avatar
By marcelstoer
#84369 Lua modules are NOT included in the firmware. You need to store ds18b20.lua on the file system. Hence, the error "no file 'ds18b20.lua'".

It's a bug that the cloud builder still lists the ds18b20 C module. I'll fix that.

Thanks for the hint about the typos. I just fixed it: ... 0c80207d1c