Current Lua downloadable firmware will be posted here

User avatar
By xtal
#34211 Try flashing with a totally different fw ie AT/Basic/Espruino etc, [ flashing 096 then back to 140 did not help]...
Then try reflash
I have had 1.4.0 issues -loading fw and had to REPLUG power to clear issue-- this has occured several times.....
-- this could be related to approaching memory limits

I had this prob with NodeMCU sdk 1.4.0 , BUT the very 1st time I flashed ok using old flasher, BUT had c:send problems...
So I flashed back to NodeMCU dev0.9.6 (old reliable - just memory shy)
Later I spent about 2 weeks trying to get 1.4.0 to flash, then tried this last flasher using 1 file loading @0x00000
and like magic 9600 baud work 115200 give err msg's 76800? output only ?
Have had no issues since, Other than C:send and not enough memory.... :oops:
User avatar
By xtal
#34214 Also found this info.........

up vote
down vote
You have two problems

1) The output you see (ets Jan 8 2013,rst cause:2, boot mode:(3,6)) is printed by the startup (bootloader) code. After that, the communication continues on a different baudrate (IIRC either 9600 or 115200 baud, depending on the firmware revision).

2) The 3.3V output of an FT232 can't deliver the current required by an ESP8266: not by a wide margin. Use a separate 3.3V supply. Probably the ESP8266 crashes due to too low voltage during or right after startup.

shareimprove this answer
answered Apr 15 at 21:31

Wouter van Ooijen

Wouldn't adding a 3.3k Ohm pull up resistor in serial be a good option to bring up the amperage for the ESP8266 to the needed 215mA at full broadcast? – Dwight Spencer May 19 at 20:21
A pull-up resistor connected in series?? And NO, that wouldn't be a solution however you connect it. – Wouter van Ooijen May 19 at 20:54

Guess your right about the resistor, it worked but wasn't very stable. However a 1000uF capacitor did the trick, no extra power source needed. Kind of feel like 1kuF is a bit over kill. Any suggestions on a better size? – Dwight Spencer May 26 at 2:15

For this application (buffering for a long power draw) I would not consider 1mF big. In this situation I would try to find the minimum value that works and then I would (for production) take one at lesast 10 times as large. – Wouter van Ooijen May 26 at 6:23
User avatar
By kamal sonani
#36231 hello,

i faced same problem and i followed as above describe but i cant find anything,

i just repeat my all process that i done first time, and after what u need is ..........

just connect reset pin to ground and remove GPIO-2 from ground (you'll connect after ... )
User avatar
By odilon
#36463 Hi.

I have this issue, but can't resolve. My board is a ESP-01, chip 25Q80ASSIG, 8Mbits. Flash it with this release: ... 21e7d2f2d1

I use to flash it, on Ubuntu 15.04

I can access the ESP-01 with a USB TTL converter CH340, but can't do with a Arduino Uno Genuino board. Try with 3 different boards.
I use too a 3.3v power for the ESP-01 module.

Some sugestion, please ?
Thank you. Sorry my bad english.