Current Lua downloadable firmware will be posted here

User avatar
By Imarock
#43712 Hi,

i've searched many hours for a solution without succes.
I tried to flash NodeMCU on my ESP12F.
I used the build from:
I have Linux and flashed via a FTDI232 with:
Code: Select allsudo python2 esptool/ --port /dev/ttyUSB0 write_flash 0x0000 nodemcu-master-7-modules-2016-01-29-14-59-03-integer.bin

According to the output of esptool, the flashing worked.
After resetting and changing GPIO0 from GND to VCC there evrytime comes some gibberish followed by one of this three error messages:
  • Code: Select alldon't use rtc mem data
  • Code: Select allSelf adjust flash size.
  • Code: Select allr�
     ets Jan  8 2013,rst cause:4, boot mode:(3,6)

    wdt reset
    load 0x40100000, len 26636, room 16
    tail 12
    chksum 0xa7
    ho 0 tail 12 room 4
    load 0x3ffe8000, len 2260, room 12
    tail 8
    chksum 0xe1
    load 0x3ffe88d4, len 8, room 0
    tail 8
    chksum 0x3c
    csum 0x3c

When the third error message comes, the ESP repeatedly reboots and outputs the same text again
As far as I know "rst cause:4" means watchdog reset

The ESP is connected to good power supply unit
CH_PD is pulled up
GPIO15 pulled down
VCC(FTDI) connected to VCC(ESP) and VCC of the PSU and the same with GND
The FTDI is turned to 3.3V

I'm new to the ESP so maybe I did some fundamental errors.
I'm happy with every hint ;)
User avatar
By TerryE
#43742 The baud rate has nothing to do with this. Getting the right esp_init_data_default.bin does. Read Flashing the firmware for more info.