Downloading and installing the new Arduino IDE for ESP8266

Moderator: igrr

User avatar
By lrossel
#68274 In my project I need to read data from a file in sd card.

In order to learn how to use it, I'm trying the included example in the SD library for the Arduino IDE 1.8.3 "Cardinfo.ino"

I'm still not connected the ESP8266 to the computer USB port, I'm still just trying to compile the sketch

SD card test

This example shows how use the utility libraries on which the'
SD library is based in order to get info about your SD card.
Very useful for testing a card when you're not sure whether its working or not.

The circuit:
* SD card attached to SPI bus as follows:
** MOSI - pin 11 on Arduino Uno/Duemilanove/Diecimila
** MISO - pin 12 on Arduino Uno/Duemilanove/Diecimila
** CLK - pin 13 on Arduino Uno/Duemilanove/Diecimila
** CS - depends on your SD card shield or module.
Pin 4 used here for consistency with other Arduino examples

created 28 Mar 2011
by Limor Fried
modified 9 Apr 2012
by Tom Igoe
// include the SD library:
#include <SPI.h>
#include <SD.h>

// set up variables using the SD utility library functions:
Sd2Card card;
SdVolume volume;
SdFile root;

// change this to match your SD shield or module;
// Arduino Ethernet shield: pin 4
// Adafruit SD shields and modules: pin 10
// Sparkfun SD shield: pin 8
const int chipSelect = 4;

void setup() {
// Open serial communications and wait for port to open:
while (!Serial) {
; // wait for serial port to connect. Needed for native USB port only

Serial.print("\nInitializing SD card...");

// we'll use the initialization code from the utility libraries
// since we're just testing if the card is working!
if (!card.init(SPI_HALF_SPEED, chipSelect)) {
Serial.println("initialization failed. Things to check:");
Serial.println("* is a card inserted?");
Serial.println("* is your wiring correct?");
Serial.println("* did you change the chipSelect pin to match your shield or module?");
} else {
Serial.println("Wiring is correct and a card is present.");

// print the type of card
Serial.print("\nCard type: ");
switch (card.type()) {

// Now we will try to open the 'volume'/'partition' - it should be FAT16 or FAT32
if (!volume.init(card)) {
Serial.println("Could not find FAT16/FAT32 partition.\nMake sure you've formatted the card");

// print the type and size of the first FAT-type volume
uint32_t volumesize;
Serial.print("\nVolume type is FAT");
Serial.println(volume.fatType(), DEC);

volumesize = volume.blocksPerCluster(); // clusters are collections of blocks
volumesize *= volume.clusterCount(); // we'll have a lot of clusters
volumesize *= 512; // SD card blocks are always 512 bytes
Serial.print("Volume size (bytes): ");
Serial.print("Volume size (Kbytes): ");
volumesize /= 1024;
Serial.print("Volume size (Mbytes): ");
volumesize /= 1024;

Serial.println("\nFiles found on the card (name, date and size in bytes): ");

// list all files in the card with date and size | LS_DATE | LS_SIZE);

void loop(void) {


But, when I try to just compile, IDE shows the following error:

Arduino:1.8.3 (Windows 10), Tarjeta:"NodeMCU 1.0 (ESP-12E Module), 80 MHz, 115200, 4M (3M SPIFFS)"

In file included from C:\Program Files (x86)\Arduino\libraries\SD\src/utility/Sd2Card.h:26:0,

from C:\Program Files (x86)\Arduino\libraries\SD\src/utility/SdFat.h:29,

from C:\Program Files (x86)\Arduino\libraries\SD\src/SD.h:20,

from C:\Program Files (x86)\Arduino\libraries\SD\examples\CardInfo\CardInfo.ino:24:

C:\Program Files (x86)\Arduino\libraries\SD\src/utility/Sd2PinMap.h:510:2: error: #error Architecture or board not supported.

#error Architecture or board not supported.


exit status 1
Error compilando para la tarjeta NodeMCU 1.0 (ESP-12E Module).

I have:
ESP8266 NodeMCU
And the SD Card reader:

It looks like the ESP8266 board is not supported by the library, but I was looking at google for some other way to accesss SD card from ESP8266 and didn't find any other way than using the SD library.

Any ideas?
User avatar
By lrossel
#68302 Thanks for accept my post. But I solved this issue a few hours after I uploaded to the forum.

The problem was that I was using a not stable version of the board.

I downgraded the board to stable release 2.3.0 and now I can work with the sd library.