Downloading and installing the new Arduino IDE for ESP8266

Moderator: igrr

User avatar
By Wangon Kwak
#84163 Hello everyone.
I am currently working on an AT communication project for Arduino Mega and ESP8266 ESP 07S.
We are having some technical issues and would like to ask a question.

First of all, the parts list I currently have is:
Arduino Mega
FTDI converter
ESP 07S + Break out board (soldered)
DC to DC conveter

The pinout at the time of the firmware update is as follows:
I soldered it to the breakout board so no resistors were connected at the time.
PIN Serial Adapter
RESET <-3.3V
CH_PD <-3.3V
VCC <-3.3V
GPIO0 <-3.3V
After updating the firmware, I received the following message.
Leaving ....
Failed to leave Flash mode
Thus, we determined that the firmware was updated successfully.

After that, I tried to get an AT response using a serial monitor by changing the pinout.
The other pinout is as follows:
PIN Serial Adapter
RESET <-3.3V (pull up)
CH_PD <-3.3V (pull up)
VCC <-3.3V (by DC to DC Conveter)
GPIO0 <-3.3V (pull up)
GPIO15 <-GND (pull down)
GND <-GND (Connected to VCC and 100nF Capacitor.)
RX <-TX (I soldered it to the breakout board so no resistors were connected at the time.)
Here is the code I used:
#include <SoftwareSerial.h>

void setup ()
uint32_t baud = 115200;
Serial.begin (baud);
Serial2.begin 115200;

Serial.print ("SETUP !! @");
Serial.println (baud);

Serial2.println ("AT \ r \ n");

void loop ()
while (Serial2.available ()> 0)
char a = ();
if (a == '\ 0')
if (a! = '\ r' && a! = '\ n' && (a <32))
Serial.print (a);

while (Serial.available ()> 0)
char a = ();
Serial.write (a);
Serial2.write (a);
No AT response has been received with the current serial monitor.
Even if I changed both the baud rate of the code and the baud rate of the serial monitor, I could not receive a response.
I have connected both pull up and pull down resistors and not connected resistors.
But the result was the same.

So I tried to upload a Blink example using FTDI Converter without using Arudino Mega.
pinout was the same as the firmware update.
But this didn't work either.

Currently, Arudino Mega cannot communicate with ESP 07S, nor can it communicate with FTDI Converter.
So the question I would like to ask is:

1. I wonder if I pinout wrong with ESP 07S.
2. I want to determine whether the ESP 07S is malfunctioning. Is there a proper way to judge this?
In addition to the attempts mentioned above, there are various ways of connecting and proceeding, so I suspect that the device is broken.
3. I hope there is no failure next time. Is there a way to connect securely?
4. If you have anything else to point out, please tell me!

Finally, thank you for reading this long article, and thank you for your lack of communication using the translator.
When I call Esp 07s AT, it's so eager to get an OK.