Downloading and installing the new Arduino IDE for ESP8266

Moderator: igrr

User avatar
By DINK74
#87322 Hi, folks!

I'm quite new to all this Arduino stuff - I bought an original Arduino Uno Starter Kit and it works fine with IDE. Then I wanted to build separate project on different board so I've chosen WEMOS D1 WiFi.
I've installed ESP8266 2.7.1 on Arduino IDE 1.8.12 and tried to upload simple sketch (Blink). But all I got is "esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header".
The board LEDs ON & SCK are both lit. While uploading another LED is blinking irregularly (the one by the edge of ESP8266 chip). I tried few different boards & connection speeds but with no success. What am I missing? Any ideas?
Arduino: 1.8.12 (Windows 10), Board: "LOLIN(WEMOS) D1 R2 & mini, 80 MHz, Flash, Legacy (new can return nullptr), All SSL ciphers (most compatible), 4MB (FS:2MB OTA:~1019KB), v2 Lower Memory, Disabled, None, Only Sketch, 115200"

Executable segment sizes:
IROM : 228492 - code in flash (default or ICACHE_FLASH_ATTR)
IRAM : 26792 / 32768 - code in IRAM (ICACHE_RAM_ATTR, ISRs...)
DATA : 1248 ) - initialized variables (global, static) in RAM/HEAP
RODATA : 688 ) / 81920 - constants (global, static) in RAM/HEAP
BSS : 24880 ) - zeroed variables (global, static) in RAM/HEAP

Sketch uses 257220 bytes (24%) of program storage space. Maximum is 1044464 bytes.
Global variables use 26816 bytes (32%) of dynamic memory, leaving 55104 bytes for local variables. Maximum is 81920 bytes.
esptool.py v2.8
Serial port COM9
Connecting........_____....._____....._____....._____....._____....._____.....____Traceback (most recent call last):
File "C:\Users\dink\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.7.1/tools/upload.py", line 65, in <module>
esptool.main(cmdline)
File "C:/Users/dink/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.1/tools/esptool\esptool.py", line 2890, in main
esp.connect(args.before)
File "C:/Users/dink/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.1/tools/esptool\esptool.py", line 483, in connect
raise FatalError('Failed to connect to %s: %s' % (self.CHIP_NAME, last_error))
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header
_
You do not have the required permissions to view the files attached to this post.
User avatar
By xtal
#87338 Your print out is close to mine except I do not see the top 2 lines? Not sure what that means.
I,ve seen this error. I think it is tied to the com port, some times , recompiling works. Some times I need to
stop serial monitor the restart serial monitor. I have 1 time had to reload 1,8.12 was getting a lot of errors.
FYI:
There are at least 3 flavors of WEMOS R1 / R2 / R3 , not sure if this is offical or not....
From what I've read you board looks like R1 [ esp-12E per the antenna? ] . My 1st 2 WEMOS were said to be R2, but I think are R1 with esp12-F [ per antenna ] I ordered an R2 last week , the board pin outs are different,
It won't support ARDUINO shields. The last 3 WEMOS I ordered were R3? . They have the arduino pinout.
The R1 and R3 have A0 buttom left .
The R2 has A0 + SDA, SCL and GPIo's to Board pins are screwy, so I'd say stay with R1/R3..

My WEMOS R1/R3 will support 4 relay Catalex shield directly.
I am using I2c LCD using 5 volt and DS3231 using 3.3 volt , I'm running the the SDA/SCL to both with no lvl shifting.
[ the only LCD input pin is grounded. so I don't think there is any issue] , both appear to be working fine.
I using GPIO0 and GPIO2 for I2c [ board pins D8 & D9 ] GPIO13-D7-relay1, 12-D6-relay2, 14-D5-relay3
4-D4-relay4, 16-D2 [ havn't found any workable use] , 5-D3

hope this may help.......