Downloading and installing the new Arduino IDE for ESP8266

Moderator: igrr

User avatar
By mford
#90139 OK, installing the Arduino IDE and connecting to an ESP8266 module can't be this hard LOL

I am trying to connect and program a HiLetgo ESP8266 NodeMCU CP2102 ESP-12E Internet WiFi Development Board Open Source Serial Wireless Module.

I have installed the IDE, added the URL for the 8266 boards, selected and installed them for the board manager. I have selected my board (NodeMCU 1.0 (ESP-12E Module). All of that is fine. However, I absolutely cannot get it to find the port.

I am running Linux (but I've also tried on Mac OSX with the same results). I've even tried with sudo to make sure it was not auth issue. I have tried 5 different micro USB cables. I have tried several different ESP modules.

So, is there perhaps a special "programming" (i.e. not charging) cable that is required?? Or have I perhaps misread the instructions - is an FTDI programmer required? The docs I've seen seem to indicate that is not needed with this module. ("Built-in Micro-USB, with flash and reset switches, easy to download no need to reset...Arduino compatible, works great with the latest Arduino IDE/Mongoose IoT/Micropython")

Can someone perhaps shed some light on what else to check?? Thanks!