Downloading and installing the new Arduino IDE for ESP8266

Moderator: igrr

User avatar
By brutzler
#33829 Hi, I had a working roundabout with Arduino IDE 1.6.5 and the last staging release: 1.6.5-1160-gef26c5f.
Installed via board manager URL.
Somehow I get lost of the files of the staging release and the preferences.txt
I modified the preferences.txt again. Made a download of the staging release, and imported again all needed libs (e.g. streaming.h).
Now I am not able to compile my project any more. It worked before the crash!
First problem is, that the compiler doesn't find the stdlibs.h any more. It is called from streaming.h.
No idea why. Arduino IDE is the same, and the staging is also the same?
User avatar
By martinayotte
#33861 First, "stdlibs.h" is not "stdlib.h" ...
The file "stdlib.h" is part of the includes provided by the "xtensa-lx106-elf-gcc" toolchain.
Do you have it installed ? it should be under "tools" directory.
User avatar
By brutzler
#33897 my fault. : stdlib.h (without s)
I reinstalled complete Arduino IDE and staging, then it worked again.