Using the new Arduino IDE for ESP8266 and found bugs, report them here

Moderator: igrr

User avatar
By Sandrino
#84502 Hi there,

with 2.6.0 and 2.6.1

when compiling any sketch that includes either:

#include <WebSocketsClient.h> from library


#include <WebSocketsServer.h>

I get a ton of error: unknown type name 'uint32_t' and cannot compile.

I I switch back to 2.5.1 everything is fine.

Any Idea ?

I-ve installed under windows 10 the same arduino ide 1.8.10 and the same libraries and there works.
i-ve installed under a new linux suse machine, same ide same lib... Same error !
tried to erase old version, tried to cancel directory but nothingh works.

also neither esp8266 sketch data file upload works:

esptool write_flash: error: argument <address> <filename>: Must be pairs of an address and the binary filename to write there
SPIFFS Upload failed!

So what is the difference between Linux an Windows .

Can someone help ???
User avatar
By Sandrino
#84580 Yes ! You did it ! Many Thanks.

Just for to help people that has the same issues, on Linux the complete path for 2.6.1 is:

/home/<whatever is your accounts name here> /.arduino15/packages/esp8266/hardware/esp8266/2.6.1/cores/esp8266

add at the very beginning:

... You should have received a copy of the GNU Lesser General Public
License along with this library; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA


#include <stdint.h> <<<<<<<<<<<<<<<<<< this line is to be added