Using the new Arduino IDE for ESP8266 and found bugs, report them here

Moderator: igrr

User avatar
By Steve Watts
#86389 I have a couple of projects which use the http service, and have started to see failures on previously working code after upgrading the community 8266 driver to v 2.6.2 and higher than it is with code. I've been working on a number of applications, all working fine up util I updated to 2.6.3. I've traced back and 2.6.2 also fails. The last time I saw this working without issue was in 2.6.1 which I have now reverted back to.

My code has become quite large, so to simplify things I've reduced it down to the attached .ino and accompanying .h include file holding the web page. I think the key issues are when the webpage is held in PROGMEM as website code held within the .ino seem to work fine.

Unfortunately I'm pretty new to the 8266 so am feeling about myself, but checking the attached code against 2.6.1 and 2.6.2 & 2.6.3 shows a distinct difference in handling (2.6.1, the other 2 just restart endlessly)


The errors I receive with this code when on 2.6.2 & 2.6.3 is below.



Exception (3):
epc1=0x4000bf64 epc2=0x00000000 epc3=0x00000000 excvaddr=0x4023d0ed depc=0x00000000

>>>stack>>>

ctx: cont
sp: 3ffffd00 end: 3fffffc0 offset: 01a0
3ffffea0: 74736f00 00000001 3ffef244 4020319e
3ffffeb0: 3ffffe00 3ffef26c 80000000 40205d80
3ffffec0: 00000001 4020107c 3ffffef0 40207ea6
3ffffed0: 00000001 4020107c 3ffef244 401000e1
3ffffee0: 3ffef244 3ffee398 3ffef244 40201b9a
3ffffef0: 3ffe0000 3fff0000 80000001 80fe84f0
3fffff00: 3ffef244 3ffee398 3ffee358 402031f2
3fffff10: 0000002f 80000000 81fefa00 0000008f
3fffff20: 80005054 74d8a7f1 40100200 00001d17
3fffff30: 00000001 3ffee398 00000001 40100170
3fffff40: 00000001 00000000 3ffee358 3ffee4f0
3fffff50: 00000001 3ffee37c 3ffee358 3ffee4f0
3fffff60: 00000001 3ffee37c 3ffee358 40203487
3fffff70: 00000000 00000000 00001388 feefeffe
3fffff80: 00000000 00000000 00000001 40100170
3fffff90: 3fffdad0 00000000 3ffee4b0 40203528
3fffffa0: 3fffdad0 00000000 3ffee4b0 40206620
3fffffb0: feefeffe feefeffe 3ffe84f0 40100bb1
<<<stack<<<

ets Jan 8 2013,rst cause:2, boot mode:(3,7)

load 0x4010f000, len 1392, room 16
tail 0
chksum 0xd0
csum 0xd0
v3d128e5c
~ld
You do not have the required permissions to view the files attached to this post.