Arduino News here

Moderator: igrr

User avatar
By igrr
jayc75 wrote:no extra info that's why I can't figure it out :)

as a workaround you need to copy libiconv-2.dll from arduino-1.6.1\hardware\tools\avr\libexec\gcc\avr\4.8.1 into the folder with arduino.exe.

Update: fixed package has been uploaded to GitHub.
User avatar
By igrr
sej7278 wrote:just what i've been waiting for!

so this is a complete copy of the arduino ide, espressif sdk and xtensa toolchain?

is there a way to separate things so that we can just use the esp01 core and libraries and chose our own sdk/toolchain without the ide? i guess i'm asking for what you've bolted on top of the ide, and can it be separated?

This is the IDE + toolchain + sdk 0.9.5 + platform description files + arduino core for ESP + some libraries.

If you want to use this without the IDE I suggest you clone the the git repository and look at the folders with esp01 core and libraries. You will need to write some makefiles to set correct paths and link the necessary libraries.

Note that if you wish to replace the SDK with a different version you should keep some modifications done to the linker script and header files.
User avatar
By ohra
#12820 Any pointers how to use this IDE alongside the normal Arduino IDE in OSX?

I don't want to mess with my install of the normal IDE, so I installed the ESP IDE elsewhere. But I guess the ESP IDE uses the same preferences as the original, so it uses a wrong library path and cannot compile ESP specific sketches. At least it fails to find ESP8266WiFi.h when I tried to build the MQTT example.
User avatar
By RichardS
#12822 Installation questions, bugs, etc all have their own threads, please post appropriately to make the information easier to manage and find!


Glad everyone is liking this!