Your new topic does not fit any of the above??? Check first. Then post here. Thanks.

Moderator: igrr

User avatar
By WillieV
#90158 Hey Guys, hope this is the right place to post this.
I have a issue with the NodeMCU Lolin V3 board (i have 80 of them!)
I successfully did code on a Geekcreit® NodeMcu that uses the software serial libraries and it works perfectly!
When i compile and upload to the Lolin it wont read anything from the software serial. i have tried all the pins i could think of ive broken the code to the bare minimum just to do a serial read and none of them work,.,
ive spent weeks now googling and looking and trying but i just cant figure out why its not working??
Does someone have any idea why it works on one and not the other??
User avatar
By WillieV
#90252 Sorry for the delay some how i didnt get any email notification of you reply.
So more info:
as i said i have 80 of the boards so ive tired on a couple of them...
Its only software serial that doesnt work- i can run all kinds of sketches on them successfully, even my main program runs fine i can interact with the wifi and serial everything except the software serial.

Im wondering if its not something with the internal clock of the module and its just messing the 2400 baud up. when i connect the software serial pins while its running i very briefly get some garbage in the serial monitor.

If i run the exact same program on the Geekcreit® NodeMcu it works and the software serial works perfectly so it has to be something specific to this board. i have read on the internet that a lot of people ad serial related issues untill they changed the baud for the normal serial.
but i have been trying for months and i just cant get the software serial to work on this boards.
Im happy to try anything anyone can suggest as i dont want 80 of them to go to waste!