Your new topic does not fit any of the above??? Check first. Then post here. Thanks.

Moderator: igrr

User avatar
By DoomedStudent7
#92571 I'm developing some Arduino code on a NodeMCU, and I have an ILI9341 hooked up to it along with some buttons.
The problem is, since flashing the code, I have been unable to flash since.

I believe this is because I've initialized the ILI9341 library using pin D3 as RST.
Whenever I plug it in, it connects for less than a second, then disconnects from my computer.
The display code (using Adafruit GFX) works as expected.

I have tried flashing blank scripts as soon as I plug it in, but there is not enough time.
I have also tried doing the same, while holding the RESET/FLASH button on the MCU.
I have not tried removing the screen yet, as I don't want to disassemble the project unless absolutely necessary.

I need to complete this project for an assignment, and I won't be able to order another MCU, but I do have at least a month to fix this.
Please advise on how I can recover this, so I can resume work on my project.
User avatar
By DoomedStudent7
JurajA wrote:D3 is io 0. it is a boot configuration pin. it must read HIGH for normal boot and LOW for flashing mode. a connected device can interfere with this

So you're saying, if I disconnect all wires, there's a possibility this could recover it?
I'll give it a try tomorrow, thanks.
User avatar
By DoomedStudent7
#92598 Yes, it worked!
Is there a list of pins that should not be used in order to properly flash? I do not want a repeat of this.
These two links suggest GPIO2 and GPIO15 (D4 and D8) also play a role in bootup, will these interfere in a similar way? ... gpio0-pins