Your new topic does not fit any of the above??? Check first. Then post here. Thanks.

Moderator: igrr

User avatar
By jc87000
#30265 Dear guy's,
It's the thrid day that i try to use these library

but i have trouble with it
I have some issue with the websocket client part. I try with the example and i have the following message on the serial port:

Connecting to NUMERICABLE-A8B3
WiFi connected
IP address:
Connection failed.

ctx: cont
sp: 3ffea780 end: 3ffea960 offset: 01b0

3ffea930: 3ffe8f88 1600a8c0 00000000 00000000
3ffea940: 3fffdc20 00000000 3ffea984 40201863
3ffea950: 00000000 00000000 3ffe9940 40100db4
I modify the different information and try to connect to my own websocket server and i have the following message:
Connecting to NUMERICABLE-A8B3
WiFi connected
IP address:
Client connected
Sending websocket upgrade headers
Analyzing response headers
Terminating socket
Handshake failed.

I also test my server with the websocket echo online client and it worked. But with your client it does not work It seems that the client nerver received data from the handshake.

Did somebody have a websocket client that worked?or canhelp me since i didnot see any trouble on the library?
My idea is to build several modulethat push captor information by websocket to the server.And server can also send information to these module.

Sorry for my poor english...
User avatar
By deepikavira
#40369 Hi, can you tell me which ESP8266WiFI.h library did you use? I am getting a compilation error ESP8266WiFi.h: No such file or directory

I am stuck with this error since a week now. Any help would be greatly appreciated.

Thanks in advance
User avatar
By NatroN
#40413 Don't know which websocket server you are using, but please be sure that it speaks WS - not WSS (websocket Secure)

That header handshake looks like wss for me. If you want to use WSS (which is highly recommended - espiaccally when you speak websocket with a server on the internet) you may need another library with supports WSS

have a look at Links2004 library