A Basic Interpreter written from scratch for the ESP8266

Moderator: Mmiscool

User avatar
By dilettante
dilettante wrote:In case it helps, I found this in the Event Log for esptool.exe:


On a hunch I tried running ESP_Basic_Flasher elevated. This prevented the crash above on clicking Format Flash but it didn't seem to do much. Reflashing the firmware and still no go.

I tried manually running:

esptool.exe -bz 4M -v -cp COM3 -cd nodemcu -ce

It starts to work and then shows two failures to connect. Maybe I have the wrong switches.

I've also read that esptool.exe is flawed in this regard and people have installed the raft of garbage to allow them to run esptool.py for this instead and had success.
User avatar
By Mmiscool
#59791 You can use the node mcu flasher. Some people who have trouble with the basic flasher have luck with that.

Also make sure your power suply is good.
User avatar
By dilettante
#59793 Weird.

Used the NodeMCU Flasher to flash with ESP8266Basic.cpp.bin and cycled power on the device.

Still no WiFi SSID, but now it blinks the blue LED once every 8 seconds or so.

Odd thing is I can flash the ancient built-in NodeMCU firmware using the NodeMCU Flasher and it comes up fine, interacts with a serial terminal as expected, etc.

Sorry to be such a nuisance.
User avatar
By dilettante
#59836 Doesn't appear that I fried the hardware or anything.

Flashed the device using the NodeMCU Flasher with the ancient built-in firmware. Cycled power. Connected using PuTTY, created an empty init.lua, and typed in a trivial "Hello World" page LUA script:

Code: Select allsrv=net.createServer(net.TCP)
        conn:send("<h1> Hello, NodeMcu.</h1>")
    conn:on("sent",function(conn) conn:close() end)

Saw the SSID, connected, and was able to hit the Hello World page with a browser.