Page 12 of 16

Re: No WiFi after Flash Basic 3.0.Alpha 65

PostPosted: Fri Dec 30, 2016 10:34 pm
by dilettante
forlotto wrote:maybe this is helpful for you?

Not really.

The thing is working fine with EVERYTHING I have tried.... except ESP8266 Basic, versions 2 and 3.

Either the code is bad in some way or else it isn't getting flashed properly. I could probably still accept that the flash memory needs to be formatted but we've been down that road without results.

As I said, I can flash things like the NodeMCU LUA and they run just fine, exactly as expected. No "repeated carving into sandstone with a sharp stick" and no "waiting 3 days for the mud tablet to harden" or anything else like that. ;)

Just flash, reboot, and it runs.

Re: No WiFi after Flash Basic 3.0.Alpha 65

PostPosted: Fri Dec 30, 2016 11:31 pm
by forlotto
I assure you in your case you are just making it more difficult by flashing other firmwares to it it almost always is a bit of a process when I flash LUA and go back takes multiple flashes and the clay inside to fire and be glazed for it to work. ;) But don't take my word for it. You MUST be persistent a real simple thing to do and persistent in flashing several times and so on so forth. Don't know what to say it is some odd thing that causes this to happen but the truth remains it does but once flashed basic and working there are no problems. When you tried the older version did the format work? What version of windows are you running can you share a link to your exact unit that you purchased? Have you tried the alternative flasher from my guide to flash the unit with the proper bin from github here https://github.com/esp8266/Basic/raw/Ne ... ic.cpp.bin ?

I guess it sucks at first to get the hang of things but you will get it the perfect way to do it you may have to balance a rake on your nose and not breathe while you are flashing IDK but the bottom line is once you see it and figure it out you will understand :P

It is not as complicated as it seems the main thing you must do is hunker down and keep at it for a while and not give up saying it is not possible. In a perfect world everything works with an easy button there is nothing wrong per say with the flash the flasher etc or at least not found the code for it is not public domain as of yet I know there was talk of possibly making the flasher public but IDK don't think it was a priority to do so.

Anyways be more persistent than the device you will prevail.

One thing that seems to help me is I flash from int to non int LUA base then I format the flash using LUA source diet or whatever. Then usually after a few flash attempts or a format and a couple of flash attempts I am back with basic. Using frighttitanic builds ....

Persist don't let this little thing kick your yeah!


Re: No WiFi after Flash Basic 3.0.Alpha 65

PostPosted: Sat Dec 31, 2016 11:28 am
by heckler

I can't help but think that you have some basic problem (no pun intended) that is causing you issues here. I have never had any difficulty flashing espBASIC to any/all of the modules that I have.

When I asked if you had ever seen the blue LED flash rapidly I was referring to when you are trying to flash basic to your module. Your response was with regard to flashing LUA to your module but what about when you try and flash basic to it?? (if I missed something then please forgive me). edit... after reading back through this thread I see where you posted a screen shot showing all the dots and then the final output so I am sure you were seeing the blue LED blinking during that process.

Have you tried to flash from a different PC?
After having attempted a flashing the espBASIC have you opened up a serial terminal connected to the modules comm port and if so what do you see when you reset the module??

That is where you should see something like this:
0▒n?▒4▒!▒▒▒▒OSAJ▒▒HTTP Port: 80
ESP Basic 3.0.Alpha 65
MAC: 1A:FE:34:D4:E1:60

Connected to infected
IP address :

Do you get anything like that?? if NOT what do you see?

All the posts here would lead one to believe that getting this espBASIC onto a module is a real tedious and unreliable effort. That is just not the case. I usually only have to try once and boom the module is up and running with a new OS and the webpage/IDE is there when I connect to its IP and ready to start entering a program or go to the settings tab and give it my LAN wifi credentials to have it connect to my lan.

Again the feedback from the comm port is VERY helpful throughout OS flashing and subsequent code development and debugging. Actually you can't use a serial terminal DURING the flashing process as the comm port is occupied by the flashing tool. But immediately after flashing the OS you can either take advantage of the new serial window that is part of the flashing tool or close the tool and open a separate (putty is my preferred) serial terminal and connect it to the comm port at 9600 baud. Then when you hit the reset button you should get something like the above example.

What have you been seeing from the serial comm port?? that will help us get you going.


Re: No WiFi after Flash Basic 3.0.Alpha 65

PostPosted: Sat Dec 31, 2016 11:45 am
by yodandy

Chiming in since I'm having the same issue. I broke down and I'm buying a few units preloaded directly from Mmiscool but would like to help figure this out in the meantime.

Here's what I get using the flashing tool right after: http://i.imgur.com/uNtwibK.png

Here's what I get after using a terminal to view http://i.imgur.com/npJIRE5.png

I've tried all of the suggestions from this thread which I summarized here: viewtopic.php?p=60096#p60096